summaryrefslogtreecommitdiff
path: root/dev-python/tzlocal/tzlocal-5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 02:38:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 02:38:53 +0100
commit0118ac4510d7b85ca62da20e4abd1286dd8bd752 (patch)
tree83ec10da0441d566914c9e66e10c8210202888ea /dev-python/tzlocal/tzlocal-5.2.ebuild
parentea6f03ddd591a238d9c5004d5ffbfaf7215c01ee (diff)
gentoo auto-resync : 23:10:2023 - 02:38:53
Diffstat (limited to 'dev-python/tzlocal/tzlocal-5.2.ebuild')
-rw-r--r--dev-python/tzlocal/tzlocal-5.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/tzlocal/tzlocal-5.2.ebuild b/dev-python/tzlocal/tzlocal-5.2.ebuild
new file mode 100644
index 000000000000..19aa8b81c205
--- /dev/null
+++ b/dev-python/tzlocal/tzlocal-5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="
+ https://github.com/regebro/tzlocal/
+ https://pypi.org/project/tzlocal/
+"
+# symlinks aren't correctly preserved in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/regebro/tzlocal/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest