summaryrefslogtreecommitdiff
path: root/dev-python/tzlocal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 02:38:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 02:38:53 +0100
commit0118ac4510d7b85ca62da20e4abd1286dd8bd752 (patch)
tree83ec10da0441d566914c9e66e10c8210202888ea /dev-python/tzlocal
parentea6f03ddd591a238d9c5004d5ffbfaf7215c01ee (diff)
gentoo auto-resync : 23:10:2023 - 02:38:53
Diffstat (limited to 'dev-python/tzlocal')
-rw-r--r--dev-python/tzlocal/Manifest2
-rw-r--r--dev-python/tzlocal/tzlocal-5.2.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/tzlocal/Manifest b/dev-python/tzlocal/Manifest
index 8a5219778769..2fc27dbf3598 100644
--- a/dev-python/tzlocal/Manifest
+++ b/dev-python/tzlocal/Manifest
@@ -1,5 +1,7 @@
DIST tzlocal-5.0.1.gh.tar.gz 25032 BLAKE2B a1b0d2d2d6422c91752332d789efddad5f14e02e0097deaea1b8df2de20686d1e73dddb1864c5c643b20f8cfce56ff28adb741f7ae74b58409a60bf0eb172057 SHA512 b89293180e82334e3c1627845516ac25d8862c799d6d56a9eff13549bfafef2e4e4b0a624e9455e4310429f50b9d82fa984b7dfe8cdd9ed3dc7325ea89c0c5b1
DIST tzlocal-5.1.gh.tar.gz 25413 BLAKE2B e4ed9c3161d049e9e00176d3ebf9a30db0f65b8c5141498d3a5d4df9e9bb299e6a307e462884640cbdaa781a3a5c07bc453e36d0eb772da0e22bbf6e474de187 SHA512 692d7ac8d04cdc3da43d75fbbd99b329b1436ef6b41540604bd65f667ac5f20219dc769d0379f41eb8723521e2ad4d2b9f399326f3d1a41b9f63c0db4341eb0d
+DIST tzlocal-5.2.gh.tar.gz 25734 BLAKE2B a2f1084e9128bc66ff861bd953a7c7a1c69e29d1e411f9489b9ff13cbadac75f42c126ddd3b66e8426e41d6376d3f9646192dc4bb5ed421b602b85bd8f109233 SHA512 21e25ef6756cb11277027dc388f779f68b1c5e03c1e7dced81fdebe0d3656c81c363a1c2f3a98344f34325bc9533d995c5a006ab7b34ff2907442a6994024d4e
EBUILD tzlocal-5.0.1.ebuild 712 BLAKE2B 77f6d957dfac4627f56fe63b3d24e97781f0d28b214ca84b1e2f5c85a2bf126238f76b0353e3c060b652cc66b78df11d7aae9bfb4dcd8d2bbd32d8a5a1af071c SHA512 d3a2ac2e9c542551f27c2843d20425bc9517073bab423a1c41d3f7705c1b2e8fd052843146369927159e2a962b816207d2eb9b87b453c0b7bae9cf7b18b3c0ab
EBUILD tzlocal-5.1.ebuild 715 BLAKE2B 76ff85c7c4f9242ba28e6fde6b27434fd21cc53dba240df8f4db5136a704e1e3b13d46e77264f8c84c6310d15d9e6330e4221c0ba8840ebc20238e653b302fac SHA512 a0bb35eab4dca7f7a1cda4a664204f5b1d8f001b1c022923cee836ceed6e5108277cf954a3c5cff33034fd43039919a49c87376e8501ed2b4046a2b7bb801e06
+EBUILD tzlocal-5.2.ebuild 715 BLAKE2B 76ff85c7c4f9242ba28e6fde6b27434fd21cc53dba240df8f4db5136a704e1e3b13d46e77264f8c84c6310d15d9e6330e4221c0ba8840ebc20238e653b302fac SHA512 a0bb35eab4dca7f7a1cda4a664204f5b1d8f001b1c022923cee836ceed6e5108277cf954a3c5cff33034fd43039919a49c87376e8501ed2b4046a2b7bb801e06
MISC metadata.xml 403 BLAKE2B c2fbd81151ee69075c53b7c7d353ac2eb207e92b5bee234591f839c751c54e20abfeb10a8ef1c7cf074d5b94c4745dd23ca1e935b41619dfdc551d2fbb955ac5 SHA512 73c29b14ace10a0b23ef59f9a10abf5f9367dfecc89743cd29a01ece71689c08f83a14612fd3a4779fcbe5382e4e33f6ffbae183c498cba8ba7776d2afbea8ab
diff --git a/dev-python/tzlocal/tzlocal-5.2.ebuild b/dev-python/tzlocal/tzlocal-5.2.ebuild
new file mode 100644
index 000000000000..19aa8b81c205
--- /dev/null
+++ b/dev-python/tzlocal/tzlocal-5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="
+ https://github.com/regebro/tzlocal/
+ https://pypi.org/project/tzlocal/
+"
+# symlinks aren't correctly preserved in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/regebro/tzlocal/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest