summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild')
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild
new file mode 100644
index 000000000000..d71392dd16a7
--- /dev/null
+++ b/dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Pure python approach of Apache Thrift"
+HOMEPAGE="https://github.com/Thriftpy/thriftpy2"
+SRC_URI="https://github.com/Thriftpy/thriftpy2/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # tests that need network access
+ rm tests/test_{tornado,rpc,sslsocket}.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pushd tests >/dev/null || die
+ epytest
+ popd >/dev/null || die
+}