summaryrefslogtreecommitdiff
path: root/dev-python/thriftpy2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/thriftpy2
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/thriftpy2')
-rw-r--r--dev-python/thriftpy2/Manifest4
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild (renamed from dev-python/thriftpy2/thriftpy2-0.4.14.ebuild)11
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/thriftpy2/Manifest b/dev-python/thriftpy2/Manifest
index c84e60522a9b..921740daccd9 100644
--- a/dev-python/thriftpy2/Manifest
+++ b/dev-python/thriftpy2/Manifest
@@ -1,3 +1,3 @@
-DIST thriftpy2-0.4.14.tar.gz 127552 BLAKE2B 4061642fb14b60ba53e0c4e6342ead25f781ee923b718a6c557235fcbfe4219b4d8944894afe9783062e7950b689b909af6be5cefe3b634a476ec582adfefbed SHA512 0b248c4999b0a97287d8db3e5b79ac687bc7e25a5478ef125b479e0baf9be9d0aa5f9eaadf0612c228133295743ba913bfe69e7fe59a8d5f854a682da9d31c50
-EBUILD thriftpy2-0.4.14.ebuild 880 BLAKE2B 8b711aa1c10aeedc3e4998f9fb50a3ebbbefa96513b4f7283b75854b961566e51e291847541accf91fd9aff58b0640a7fcff656968c44af8f73191a111fe5e22 SHA512 cb62288b5b9ca13d4bf0739effe56e5dab8c1a727b3a4955ae081e8a0a3e4d6430e6dad8872bb2ab1044e5393287cee345d0e52d17005149da8bc24e857291ff
+DIST thriftpy2-0.4.14.gh.tar.gz 127552 BLAKE2B 4061642fb14b60ba53e0c4e6342ead25f781ee923b718a6c557235fcbfe4219b4d8944894afe9783062e7950b689b909af6be5cefe3b634a476ec582adfefbed SHA512 0b248c4999b0a97287d8db3e5b79ac687bc7e25a5478ef125b479e0baf9be9d0aa5f9eaadf0612c228133295743ba913bfe69e7fe59a8d5f854a682da9d31c50
+EBUILD thriftpy2-0.4.14-r1.ebuild 939 BLAKE2B c4c817d423130a110a4a4b69d18f068f6757b0b443bf9e851486473d2323ed9af9f752cf684e2e32f2caf5ab95b584e18dd8d0795002f4e59d9d47f68d7b94a2 SHA512 36cfc0e63170e2b6308733d0674e16390cc31c2b11b7b68d258cd06e1e6b470a63fcb0326e8dfb006889741ac20b1041d4528155b4d5633cd881e7fd214a5493
MISC metadata.xml 380 BLAKE2B 570746c7985eab098e590e49d267c406ce02cbf612dda6bf2a60439aee62cbf6eefebac14af29bf5fa52c8b5fd4846b2872beb7034364abb722f706978b55987 SHA512 d20d8641eea699cfa6d1930b8c5a9a8edfe76b5ef837551c52105d2fe8d70d481862c5d5cdbe389971588b3bdf62e9fb7e1cec2e89d635650cbabed7f7f53070
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.14.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild
index 16727441076a..d71392dd16a7 100644
--- a/dev-python/thriftpy2/thriftpy2-0.4.14.ebuild
+++ b/dev-python/thriftpy2/thriftpy2-0.4.14-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Pure python approach of Apache Thrift"
HOMEPAGE="https://github.com/Thriftpy/thriftpy2"
-SRC_URI="https://github.com/Thriftpy/thriftpy2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/Thriftpy/thriftpy2/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -27,7 +27,8 @@ BDEPEND="
distutils_enable_tests --install pytest
python_prepare_all() {
- rm tests/test_tornado.py || die
+ # tests that need network access
+ rm tests/test_{tornado,rpc,sslsocket}.py || die
distutils-r1_python_prepare_all
}