summaryrefslogtreecommitdiff
path: root/dev-python/termcolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /dev-python/termcolor
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/Manifest2
-rw-r--r--dev-python/termcolor/termcolor-2.0.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index 245e8b696df8..6bc91f47d214 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1,3 +1,5 @@
DIST termcolor-1.1.0.tar.gz 3912 BLAKE2B 8d661a708eff02894b6e390befddaef1c9d14f78f0c7d10ac332fa149f7892109f77bd279c9a488a3aa4070569c92f0ce847e3911d419ff549a10555b34534fb SHA512 4bd06bf4405a9ef6c005cd4d159ef602f7fc7fccb3e57586da1187c402f4d0b9051ef930cae423065c51ff4be8a22ceae556a61a6b3c8c519d623c066c340b53
+DIST termcolor-2.0.0.tar.gz 9701 BLAKE2B 3c1d81b21788c07870724ca162828037eee11b2c472fbe4cf9c60583155a0eb665c59bbab824882038f453d539b2c3c8518b51e373deb9755205b41b517d8ed3 SHA512 3b5f937c94ba3c0eac04073851fa53123262b3de4e081635069ebd2115b51cf37f88bf129f19d356886487cbeda381921022e52b560b7cbc8a9d935bc902dc6e
EBUILD termcolor-1.1.0-r3.ebuild 547 BLAKE2B 17a7d7c1abb51c1135317a5730e151167374fba5d4e586e09a5d1e02ed8f9b7bdb2772cb61b15cd68661394de6d971f428b02bb6e61080197a162ba8548b09ae SHA512 29d4fc140d1c01815bb6e3f0e71ebe94671d5118df54370787344eafcdb88a4cc9ad4f82d4de508495832924f902350af15a260711d662f68ff1631597bcdadf
+EBUILD termcolor-2.0.0.ebuild 651 BLAKE2B f0e9bfb2fa403d17cce7b1167c008f973597c24148746d114346913f808f73fea68e6f16e7a02c76f35102e5dbab3e45ea4665f3f7f583a389c33c8df05994f1 SHA512 437a9d9fe3e27b9473ec8f89ae70e7a104987e8615bc43634b61938e3ed910ec25bcab1ee28cf4c47a647b41eaa0b1005e5bca95274f676e30370408c76a1dc7
MISC metadata.xml 469 BLAKE2B a9da957ef444f9a2537616c337073c53f3d00d2b35f9b52116c6ffebdea617014e058c66ee97afafff37841c1f6f9cbce4400236a18e9037791baad21705883e SHA512 6664c1026a6c7eb63df6d668a2ba4b4a4fbc23c5737db9a01e915b562d15d3c18196b963805ebf7a09e03ead51316d71b1a0c035813bf4c9729e0cb528e1794f
diff --git a/dev-python/termcolor/termcolor-2.0.0.ebuild b/dev-python/termcolor/termcolor-2.0.0.ebuild
new file mode 100644
index 000000000000..61b84954a4c0
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest