summaryrefslogtreecommitdiff
path: root/dev-python/termcolor/termcolor-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/termcolor/termcolor-2.0.0.ebuild')
-rw-r--r--dev-python/termcolor/termcolor-2.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/termcolor/termcolor-2.0.0.ebuild b/dev-python/termcolor/termcolor-2.0.0.ebuild
new file mode 100644
index 000000000000..61b84954a4c0
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest