summaryrefslogtreecommitdiff
path: root/dev-python/subprocess32/subprocess32-3.2.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/subprocess32/subprocess32-3.2.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/subprocess32/subprocess32-3.2.7.ebuild')
-rw-r--r--dev-python/subprocess32/subprocess32-3.2.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/subprocess32/subprocess32-3.2.7.ebuild b/dev-python/subprocess32/subprocess32-3.2.7.ebuild
new file mode 100644
index 000000000000..34149511c432
--- /dev/null
+++ b/dev-python/subprocess32/subprocess32-3.2.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A backport of the subprocess module from Python 3.2/3.3 for use on 2.x"
+HOMEPAGE="https://github.com/google/python-subprocess32"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}"/${P}-sandbox-test-fix.patch )
+
+python_test() {
+ "${PYTHON}" test_subprocess32.py || die "Tests fail with ${EPYTHON}"
+}