summaryrefslogtreecommitdiff
path: root/dev-python/subprocess32
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/subprocess32
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/subprocess32')
-rw-r--r--dev-python/subprocess32/Manifest4
-rw-r--r--dev-python/subprocess32/files/subprocess32-3.2.7-sandbox-test-fix.patch14
-rw-r--r--dev-python/subprocess32/metadata.xml12
-rw-r--r--dev-python/subprocess32/subprocess32-3.2.7.ebuild23
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/subprocess32/Manifest b/dev-python/subprocess32/Manifest
new file mode 100644
index 000000000000..f8cc5c20b479
--- /dev/null
+++ b/dev-python/subprocess32/Manifest
@@ -0,0 +1,4 @@
+AUX subprocess32-3.2.7-sandbox-test-fix.patch 672 SHA256 feb894827cf604a5831fc4c06d3ed0ee130d682482e685a2f61519859746b631 SHA512 cdfa5b9ee56df54c2d122624815e472f9dd13e101a8d221adb48d21b1f7cd0ff3187d69f91c0ed7f164ee69348ffedde22a1d32a101d1eade85d6882ad47b6d0 WHIRLPOOL 17ee59de0f019359c209c32c4930fbc79f8806ba850b42d177f816982678b29c82c081f066f3055e39f15725aa0bda42c2828621e9322709b8357751ab9f68d2
+DIST subprocess32-3.2.7.tar.gz 54240 SHA256 1e450a4a4c53bf197ad6402c564b9f7a53539385918ef8f12bdf430a61036590 SHA512 d897d6a48824991e2a63ea417ca15222f28c3a4117c9bba8cbb4eceabfba9769acce1166aafa7aee8a025d6ebe7e133ce0dd617f90cb07e11bdb73dc1e21dec6 WHIRLPOOL 41226d999895439a089a319e8b805468d1913ec098d5f92705076ae707efb59c8a92f56e1068927065c5c1060ad84388fbaaf575a6e5c4d12a2b2b1e588f3e0a
+EBUILD subprocess32-3.2.7.ebuild 573 SHA256 97fad8182aa12d358ff536621010b555aace27667e6a2c8f9d73256a952eb8f7 SHA512 01ceb834c7b05138f7969126fbbc2734085ff41af6f43b3bd6667f52b01bfe6fff547eec31967a78f61e38efd1d08394e8ce860110b6f1e0feeaceb3dd21e24c WHIRLPOOL a38a8119ce6475f7395cd121da0066e8c37cad4312a889008e9c0f7b00a1c41ff638a047f34fe45ed777c11a22fd75b922d3fd6eba26daedb19075af55a35f71
+MISC metadata.xml 393 SHA256 ec1b03759c5b7c168c659b15a6c75c36dd0f8a353c00f39ec61d09e62f16edd3 SHA512 0c015bdd15a504432cc6b804c66384260d2cf0b77ffbdc8af36a82e31e2c6ecf6a62c2c4d156afbaf30afcadcb3f5fdedff70b73a4c2381b5bc7fedcb5f36d4a WHIRLPOOL 7d5acc216b37e3cca393b7e19920bd409497b2e472deaeab2276207ae2011b82d8122d72b1e87b694a21ac11db8114d6407531f6c75cce3e86cc79d12865f91e
diff --git a/dev-python/subprocess32/files/subprocess32-3.2.7-sandbox-test-fix.patch b/dev-python/subprocess32/files/subprocess32-3.2.7-sandbox-test-fix.patch
new file mode 100644
index 000000000000..50e4a511fc4b
--- /dev/null
+++ b/dev-python/subprocess32/files/subprocess32-3.2.7-sandbox-test-fix.patch
@@ -0,0 +1,14 @@
+diff --git a/test_subprocess32.py b/test_subprocess32.py
+index c312949..000f7d6 100644
+--- a/test_subprocess32.py
++++ b/test_subprocess32.py
+@@ -538,7 +538,8 @@ class ProcessTestCase(BaseTestCase):
+ [sys.executable, "-c",
+ 'import os; '
+ 'print([k for k in os.environ.keys() '
+- ' if ("VERSIONER" not in k and "__CF" not in k)])'],
++ ' if ("VERSIONER" not in k and "__CF" not in k and '
++ ' "LD_PRELOAD" not in k and "SANDBOX_" not in k)])'],
+ stdout=subprocess.PIPE, env={})
+ try:
+ stdout, stderr = p.communicate()
diff --git a/dev-python/subprocess32/metadata.xml b/dev-python/subprocess32/metadata.xml
new file mode 100644
index 000000000000..d06e7b26e195
--- /dev/null
+++ b/dev-python/subprocess32/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">subprocess32</remote-id>
+ <remote-id type="github">google/python-subprocess32</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/subprocess32/subprocess32-3.2.7.ebuild b/dev-python/subprocess32/subprocess32-3.2.7.ebuild
new file mode 100644
index 000000000000..34149511c432
--- /dev/null
+++ b/dev-python/subprocess32/subprocess32-3.2.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A backport of the subprocess module from Python 3.2/3.3 for use on 2.x"
+HOMEPAGE="https://github.com/google/python-subprocess32"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}"/${P}-sandbox-test-fix.patch )
+
+python_test() {
+ "${PYTHON}" test_subprocess32.py || die "Tests fail with ${EPYTHON}"
+}