summaryrefslogtreecommitdiff
path: root/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-17 12:56:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-17 12:56:42 +0000
commit34fb4543abc1dae6f74171ad8dc80fa64636a941 (patch)
tree5923cd4dc2a560dba9b618db67713ae10cf92f75 /dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild
parent1536d928ae095e00db8775fecca580c10adc0af8 (diff)
gentoo auto-resync : 17:11:2022 - 12:56:42
Diffstat (limited to 'dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild')
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..6f07c443f2d4
--- /dev/null
+++ b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="https://github.com/spyder-ide/spyder-line-profiler"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/line_profiler[${PYTHON_USEDEP}]
+ dev-python/qtawesome[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-6.0.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}