summaryrefslogtreecommitdiff
path: root/dev-python/spyder-line-profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-17 12:56:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-17 12:56:42 +0000
commit34fb4543abc1dae6f74171ad8dc80fa64636a941 (patch)
tree5923cd4dc2a560dba9b618db67713ae10cf92f75 /dev-python/spyder-line-profiler
parent1536d928ae095e00db8775fecca580c10adc0af8 (diff)
gentoo auto-resync : 17:11:2022 - 12:56:42
Diffstat (limited to 'dev-python/spyder-line-profiler')
-rw-r--r--dev-python/spyder-line-profiler/Manifest1
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/spyder-line-profiler/Manifest b/dev-python/spyder-line-profiler/Manifest
index d44e6866880a..8799591d5ac5 100644
--- a/dev-python/spyder-line-profiler/Manifest
+++ b/dev-python/spyder-line-profiler/Manifest
@@ -1,3 +1,4 @@
DIST spyder-line-profiler-0.3.1.gh.tar.gz 44042 BLAKE2B a98c5770b44b3e11d2261b371e5a806087ebcb347b54745b5bdfe5c4fe3051ff862c79e96ab9a0048e83217cba65fd48a6368bf3e1d1a3f9ab09d2dd69f8ec7c SHA512 96ddc1817adfd58362ea766b95cd58ad521c1333a6bafe9fef1e117ef7ef602bc7e7bced3990d19b85c2882253d81d27940ab409a9daacf588513a405ae4d8fb
+EBUILD spyder-line-profiler-0.3.1-r1.ebuild 816 BLAKE2B 329448d4fa13d5216e26a15389d44ea744fce0be155e6162cfffaa91869130c63d9d33c484b53afe373f20600da343c47d57dc6d68d1419e4253cbe17230b848 SHA512 df243fafffed44c1c3c81b15823ecd4fbd0b609ec1061cd3dbe22affb9cb46058ae78b84d6dddb248a5c073845e828c161479bbbb69a783fdd286711de097231
EBUILD spyder-line-profiler-0.3.1.ebuild 784 BLAKE2B 6f386e12fede0472fa02882f96042477c4941564cce2d537727cc5b8bc0f3cf9ac8c0933d29254ecd3b7df116cc4389ea1259c17a1d63c122e1eda739f008468 SHA512 16325c761101c89198bbe5bbb1bfc37268358ebe9c6eeafc67c6bca78b02a334cf85aa1eb1142f5b566678b5a52a2a360d01ca272d6c0638b4cc6c0a84c82f18
MISC metadata.xml 366 BLAKE2B c32aaf9d9bc88aad26fd4df03243c046874b2f4e7fc40cc57ac85ba72c23cec611b6d2cfacdde51968fb1c012ab9bee3179c61c0d0c28c6c8854f0bed615f022 SHA512 70265f7e2c19d3d7987f5ca4904ff691e99d261a1f5bb4ad06115e706e2f9d15b26be2af4ececa29b2e48d6ac98d56cc1ba23756d55ee0e97e5304aa3713b7b9
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..6f07c443f2d4
--- /dev/null
+++ b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="https://github.com/spyder-ide/spyder-line-profiler"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/line_profiler[${PYTHON_USEDEP}]
+ dev-python/qtawesome[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-6.0.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}