summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild')
-rw-r--r--dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild
new file mode 100644
index 000000000000..384fc0ddd4c3
--- /dev/null
+++ b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Make Sphinx better at documenting Python functions and methods"
+HOMEPAGE="
+ https://github.com/python-trio/sphinxcontrib-trio
+ https://pypi.org/project/sphinxcontrib-trio
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+)"
+
+# AttributeError: 'Sphinx' object has no attribute 'add_stylesheet'
+#distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/python-trio/sphinxcontrib-trio/issues/260
+ epytest --deselect tests/test_sphinxcontrib_trio.py::test_end_to_end
+}