summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-trio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/sphinxcontrib-trio
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/sphinxcontrib-trio')
-rw-r--r--dev-python/sphinxcontrib-trio/Manifest3
-rw-r--r--dev-python/sphinxcontrib-trio/metadata.xml17
-rw-r--r--dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild38
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-trio/Manifest b/dev-python/sphinxcontrib-trio/Manifest
new file mode 100644
index 000000000000..85f4d23cf9c7
--- /dev/null
+++ b/dev-python/sphinxcontrib-trio/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-trio-1.1.2.tar.gz 24131 BLAKE2B 5ddaf5ed6c85905275e206fdd966745ce4dd7296595c488864df291cb7202725ccab722f306dd9d6c27d660f5cb3e43bf9ab2fe50e8aa5a7232c2615dddbdfd0 SHA512 cb90f37f463fbdd3f810eb6d76b4bdaaabe83317de0ad747fcee55980849d691e272884ecdfcbee58851cf536f268f2520caba281d7550fe3250e92c69164434
+EBUILD sphinxcontrib-trio-1.1.2.ebuild 994 BLAKE2B ee66aa5670da27b77ce7924dc59f9d28db58b6e8a579aca18ee738804a7abd547f00743733c07f2269ded748b899ee03a8072b3853c29f1b9cd5bdfe6e1050a5 SHA512 7968d02e4c7064528fc4a7b62eac4c70d769403f088229e7872f5fa5d323dba7c402c34b2862ffe9f3bc8262eabae0e27ce9efd8b3eb9752967d0fa9193e6f4e
+MISC metadata.xml 1117 BLAKE2B 947c7c2b888c24101db258e47efffbc6db4873c99cb9dd5c2076dfc25d25de04736db46d9fff88667f57f8f09f01c17f2937b2d7f641a8b7cb5baecf9d3d2b2e SHA512 57341896ef4194b5ddab0485e46bd8567c4514518c02e1049db21e9174c420175e47644d948c9c1a6dc03bd4248f235d2d811c6252be7c67f624e0b2883ff2ed
diff --git a/dev-python/sphinxcontrib-trio/metadata.xml b/dev-python/sphinxcontrib-trio/metadata.xml
new file mode 100644
index 000000000000..0cfc4ecfa6bd
--- /dev/null
+++ b/dev-python/sphinxcontrib-trio/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <longdescription lang="en">
+This sphinx extension helps you document Python code that uses async/await, or abstract methods, or context managers, or generators, or … you get the idea. It works by making sphinx’s regular directives for documenting Python functions and methods smarter and more powerful. The name is because it was originally written for the Trio project, and I’m not very creative. But don’t be put off – there’s nothing Trio- or async-specific about this extension; any Python project can benefit. (Though projects using async/await probably benefit the most, since sphinx’s built-in tools are especially inadequate in this case.)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">python-trio/sphinxcontrib-trio</remote-id>
+ <remote-id type="pypi">sphinxcontrib-trio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild
new file mode 100644
index 000000000000..384fc0ddd4c3
--- /dev/null
+++ b/dev-python/sphinxcontrib-trio/sphinxcontrib-trio-1.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Make Sphinx better at documenting Python functions and methods"
+HOMEPAGE="
+ https://github.com/python-trio/sphinxcontrib-trio
+ https://pypi.org/project/sphinxcontrib-trio
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+)"
+
+# AttributeError: 'Sphinx' object has no attribute 'add_stylesheet'
+#distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/python-trio/sphinxcontrib-trio/issues/260
+ epytest --deselect tests/test_sphinxcontrib_trio.py::test_end_to_end
+}