summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-testing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-python/sphinx-testing
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-python/sphinx-testing')
-rw-r--r--dev-python/sphinx-testing/Manifest2
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sphinx-testing/Manifest b/dev-python/sphinx-testing/Manifest
index b72cd12b750e..24c32e3e87b2 100644
--- a/dev-python/sphinx-testing/Manifest
+++ b/dev-python/sphinx-testing/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-testing-0.7.2.tar.gz 11040 BLAKE2B 503e38eabfe8dbe28942f9165a83db2dec0f9ac52e1e55f7298848b7a6b55244e1b5623bfda7f4e1380eab16ef81cf51c6bc11e919a8b45506f17759ae0ee181 SHA512 d267c74d97443db2df69914a825da969021e37fc61b8a664ef382504fa826387a95230bf9259b58c6f26721f33985fa2168d2714342a2166b59740cf1b3ad724
+DIST sphinx-testing-1.0.1.tar.gz 11513 BLAKE2B 46ede243507a0d90b2ad4b918deadb818491bb0ed15ce41886040c52650f9fd348ff57c03766fd1e7719bbb54726f8915e091cf94a5396da946102ca49fd07b2 SHA512 2d377c0c6fe8e34a463b35e96938507a3ca35fa06cd19a2682eb55825e1b88982a80a02ebb9a02a47f11ca5e8fe6a5b9e5c8114d955fa3b774e0148e82121818
EBUILD sphinx-testing-0.7.2.ebuild 670 BLAKE2B 91b3ea4398ba4e34b54136fb3e101a407cbebff496b6236ef44b462494d579c5fea5b7e216ac2cec3f042b6d6a07a78508ff4dc8808df9a12d7dfe9980e02cbb SHA512 f707f939fbed55ac43e1dd8cb025623de0cbc84fa91aac7cf6de9a2292c6c5bcec448765a1e655535369a09ecb5fe46302127d688e4c631783a752b1ed0a219e
+EBUILD sphinx-testing-1.0.1.ebuild 861 BLAKE2B 9607853fc044848f4a64c547c522a3b90e1a01d9766d8b2a74be7ccf9740b2e24a4b94ad382f60b1f35b35dd4529fdc88006fcd395a99a4d2c940778c4455974 SHA512 7e6996b3b5017ade03c6532860931305a98adc2d62eb6b0e0bee49c8f485acde24aaa198714e1c7b52b82b49a470058c0b1caf731fa1970669ec3b0e8ced87a6
MISC metadata.xml 340 BLAKE2B 9a1df283aab1420d7818f4661b57f6d60cd734016c3711c633b9a6a11c401c8603503530fa5e1f50940bd28c1fed83196c1c543d16b5217b996f6afef23175a8 SHA512 f5299851dc6aa3c3ad1109123ac6c4eb5b5c7e1177fa1f068da5cef0920bbece63a8f1c424c5b95addf661e5a7d15a05a427676f6c272a54741495c77e316b78
diff --git a/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild b/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild
new file mode 100644
index 000000000000..d4cb8e44dbb8
--- /dev/null
+++ b/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ )"
+
+python_test() {
+ # NB: while tests don't stricly use nose, they rely on some side
+ # effects of using it
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}