summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild')
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild b/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild
new file mode 100644
index 000000000000..d4cb8e44dbb8
--- /dev/null
+++ b/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ )"
+
+python_test() {
+ # NB: while tests don't stricly use nose, they rely on some side
+ # effects of using it
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}