summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-23 15:49:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-23 15:49:20 +0100
commit41ba6a36cf63678ca63fdd9788e84e3e032dc4ba (patch)
treed0c7e74375d68297d183bd73957bc1f92623479c /dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild
parent7795d9198ccb546ad792af2694399b516fc244ac (diff)
gentoo auto-resync : 23:08:2023 - 15:49:20
Diffstat (limited to 'dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild')
-rw-r--r--dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild b/dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild
new file mode 100644
index 000000000000..e9672290f15e
--- /dev/null
+++ b/dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="sphinx_press_theme"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Sphinx-doc theme based on Vuepress"
+HOMEPAGE="https://github.com/schettino72/sphinx_press_theme"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"