summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-press-theme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-23 15:49:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-23 15:49:20 +0100
commit41ba6a36cf63678ca63fdd9788e84e3e032dc4ba (patch)
treed0c7e74375d68297d183bd73957bc1f92623479c /dev-python/sphinx-press-theme
parent7795d9198ccb546ad792af2694399b516fc244ac (diff)
gentoo auto-resync : 23:08:2023 - 15:49:20
Diffstat (limited to 'dev-python/sphinx-press-theme')
-rw-r--r--dev-python/sphinx-press-theme/Manifest3
-rw-r--r--dev-python/sphinx-press-theme/metadata.xml17
-rw-r--r--dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild20
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sphinx-press-theme/Manifest b/dev-python/sphinx-press-theme/Manifest
new file mode 100644
index 000000000000..782d88903638
--- /dev/null
+++ b/dev-python/sphinx-press-theme/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx_press_theme-0.8.0.tar.gz 68878 BLAKE2B d03b361b4447a78575f7c0887bd01fd2e685030babb3062da67c571715e0f82eafb889e872dab9817a2813344172b3f3b94193aa10905bbbe2f45b64a9682cda SHA512 b4393a9200b42f414401ff5419fc51db8dd248c677a8ba234f2ae8cf5190cef2083c3ae25b7f5435223917a7c3e471dace6987e323fc885456af2467cedc8a78
+EBUILD sphinx-press-theme-0.8.0.ebuild 458 BLAKE2B ad61fdbd312fe7114876ccbf35100413ba0cb8a3249c26bcfee9d3f8f902fff0f1ea8ef6a7a795bd7a5099b326546aef548c30c6dd79bdc6193e90d7e1cb1871 SHA512 6782436a0e3ca6f32ef04cbdfa8771a99464e863854639bec81ad7d318fb4fd243ac593d81c609edfc2ec776b1df0f5fc22b838785b868fd052969f667b07416
+MISC metadata.xml 576 BLAKE2B a2810f29bb4a08de1f9a60484ef93865cae628002754681c96c4f3321a442d34fe15965b9dc4027ee4f423cb7d1b45e17d94b5919004b7f1be9534a7e9e4b049 SHA512 85a32a9682b26a1d159c423bd4086b555b7d430d41e681efe19a1604145e5aa90c397dfcb614f1f972ca6e5add9a1db1ca6cf016c49599bb1a9b88e1ff57df35
diff --git a/dev-python/sphinx-press-theme/metadata.xml b/dev-python/sphinx-press-theme/metadata.xml
new file mode 100644
index 000000000000..e6c10d435a26
--- /dev/null
+++ b/dev-python/sphinx-press-theme/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>negril.nx+gentoo@gmail.com</email>
+ <name>Paul Zander</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">schettino72/sphinx_press_theme</remote-id>
+ <remote-id type="pypi">sphinx-press-theme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild b/dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild
new file mode 100644
index 000000000000..e9672290f15e
--- /dev/null
+++ b/dev-python/sphinx-press-theme/sphinx-press-theme-0.8.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="sphinx_press_theme"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Sphinx-doc theme based on Vuepress"
+HOMEPAGE="https://github.com/schettino72/sphinx_press_theme"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"