summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-11 14:19:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-11 14:19:56 +0100
commit34d4f34516ab568ad4ea24fc16ee0ad9ec8ad079 (patch)
tree3339f6fc30715c2fbe1d20281f6ddc53eda3f9b4 /dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild
parent32eff0cac517b699efc32b86520bac482961a57f (diff)
gentoo auto-resync : 11:08:2022 - 14:19:56
Diffstat (limited to 'dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild')
-rw-r--r--dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild b/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild
new file mode 100644
index 000000000000..e6f2a27ae78a
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_alpha/.a}
+DESCRIPTION="A modern skeleton for Sphinx themes"
+HOMEPAGE="
+ https://github.com/pradyunsg/sphinx-basic-ng/
+ https://pypi.org/project/sphinx-basic-ng/
+"
+SRC_URI="
+ https://github.com/pradyunsg/sphinx-basic-ng/archive/${PV/_alpha/.a}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/sphinx-6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ local HTML_DOCS=()
+ build_sphinx tests/barebones
+ rm -r tests/barebones/_build || die
+}