summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-basic-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-11 14:19:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-11 14:19:56 +0100
commit34d4f34516ab568ad4ea24fc16ee0ad9ec8ad079 (patch)
tree3339f6fc30715c2fbe1d20281f6ddc53eda3f9b4 /dev-python/sphinx-basic-ng
parent32eff0cac517b699efc32b86520bac482961a57f (diff)
gentoo auto-resync : 11:08:2022 - 14:19:56
Diffstat (limited to 'dev-python/sphinx-basic-ng')
-rw-r--r--dev-python/sphinx-basic-ng/Manifest2
-rw-r--r--dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinx-basic-ng/Manifest b/dev-python/sphinx-basic-ng/Manifest
index 86b97a4287fa..f3788272d91e 100644
--- a/dev-python/sphinx-basic-ng/Manifest
+++ b/dev-python/sphinx-basic-ng/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-basic-ng-0.0.1.a11.gh.tar.gz 21539 BLAKE2B 31707bc8f3c6cd0c1af1aeff309543889119d33e5f5ae33194b58f88a0ff6ec424c5b876fef36b64161932ebb69c0f6108801697b49d47e10ad13affcf89e1fa SHA512 e9f9278a360d2c8d25a6679134d2d54b37c9f2e55285592fa910c85b2f8bfd4ab13d117b7078cb67d862703f8054c3d3a3ca68152551d67a26d7c1a8b75952ff
+DIST sphinx-basic-ng-0.0.1.a12.gh.tar.gz 23821 BLAKE2B 905186227d725d6f62c0f4c5b4df49ada8817dd44a4000b23b62e60ce5ca3bef4a4046c9543a07a7b0cc0c12dd5278dc783633324fbe113cf453ee540fa97ff7 SHA512 6df9445306b27ae4b29b338773fa4adcee631b4be04fdde674855dfcb683f7cf7ad3c40124c85353608b63523738b6bc83c6c4f4b2b212cafa41d38462ffcac4
EBUILD sphinx-basic-ng-0.0.1_alpha11.ebuild 931 BLAKE2B bf63661aacb299ce2c685d940f4f4219caa3037b6f74131d74101152c4ec5264fa387262bee454821e8f7df2ed89be26903a22542010f48c2486a19785ba6ef5 SHA512 311b332f6b3fef12a4e2d0488a4841793fa7f7faf39991ef9b9696b1f76ab62e5c17a81b0b5360ce6a9f02ece335dec52cf5423ab2a0e2ebe4e8676400c2f668
+EBUILD sphinx-basic-ng-0.0.1_alpha12.ebuild 939 BLAKE2B b74d9d5865dbfac8cde9a42fa94db01b2f8fdc7e325a72eba0a37a427aac9c88099f711e1f78f2222df7d4dc8e10557ce4278ef9c138ec376e63c6e3472ec603 SHA512 e1314d676726118f0f62215a957640558da118ee063f4d078c35ce3f93391ed0029106b7b02b6a9ce276292b3bebe064e75e7da235e893d6d22cbef8468b09c8
MISC metadata.xml 362 BLAKE2B a93dc662c8ab618397c8d0504342e8f1bd74226b131ea4ca07771cdeb75eb8947451b4353c0da16760f07f935ebb75adcdef4f189ff39e0cf707d03e8fa319e2 SHA512 fb27130b3fcff9043b3ad33e34c92f638cae46d526dcbe77cfe088abf80e6b89992edb1e0b571a5a2447bc6c8ba31ae84776d153067a33b5d6d14326149e7f46
diff --git a/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild b/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild
new file mode 100644
index 000000000000..e6f2a27ae78a
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_alpha/.a}
+DESCRIPTION="A modern skeleton for Sphinx themes"
+HOMEPAGE="
+ https://github.com/pradyunsg/sphinx-basic-ng/
+ https://pypi.org/project/sphinx-basic-ng/
+"
+SRC_URI="
+ https://github.com/pradyunsg/sphinx-basic-ng/archive/${PV/_alpha/.a}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/sphinx-6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ local HTML_DOCS=()
+ build_sphinx tests/barebones
+ rm -r tests/barebones/_build || die
+}