summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 20:59:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 20:59:46 +0100
commit1d4cc2fdaa7a04ed1fe39b6cf1d892bd83bd8030 (patch)
tree15bcf4c47e609ca1bd3dc164c91a9cfbe566dd3f /dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild
parent1503b28e7a30c164cab750c27268f704b8a5cec6 (diff)
gentoo auto-resync : 26:07:2022 - 20:59:46
Diffstat (limited to 'dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild')
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild
new file mode 100644
index 000000000000..3a7bbebfd20c
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/astroid[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+# Test requires pypi download w/ internet: https://github.com/readthedocs/sphinx-autoapi/issues/329
+EPYTEST_DESELECT=(
+ tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample-override_conf2-AutoAPI
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc