summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-autoapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 20:59:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 20:59:46 +0100
commit1d4cc2fdaa7a04ed1fe39b6cf1d892bd83bd8030 (patch)
tree15bcf4c47e609ca1bd3dc164c91a9cfbe566dd3f /dev-python/sphinx-autoapi
parent1503b28e7a30c164cab750c27268f704b8a5cec6 (diff)
gentoo auto-resync : 26:07:2022 - 20:59:46
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest2
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 931d9c5cdd91..b28bee97dae3 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-autoapi-1.8.4.tar.gz 83541 BLAKE2B 05d706fda6da4aea55e535a995ef01dc54269fa8e452c51c9bf2cec2e596ccec20191b8cb3c0cde1b93daa4f5d85074a293c9fd449d99d3c494ba20c6cee2df8 SHA512 10b4d87e1046ad372a3491006cd4bece8334fc398025f98654781c83ee200045d707f3293a031f8cf0abe5d20a111e7ded864f2b6deffe5222b331ca8c9b688b
+DIST sphinx-autoapi-1.9.0.gh.tar.gz 84730 BLAKE2B 31547c0dee076736d65867d9856e713581c440d2b1f01b7ebcbe09b31a7bf2979346bcbe18d6064fd5656b7d7dab9149c67fe79f0db7e5757c2581370c11a8cd SHA512 f098f474d9821c974c2ede77de30f3317c87cb87ec00b7a1c021add1d07a1ed59fa3b4165edf2b7f5165004ba9c717394962154098bc89b52989d0e604c542f1
EBUILD sphinx-autoapi-1.8.4.ebuild 979 BLAKE2B 5e32cd651f8490e4b15680b97a54a6fc357a2ccd492fe281ab04a2d14b58f3afb5618c3fa7f6460818aa62ba82341506d10ecebb72bdbd085fed361d0f6c0e1f SHA512 41ffe1a37865cb21bfb4aca259d21ade63ed64c24d9092aefc155346ac1fccd86010f9c12934c6f53fbb93bf38f7b4fd1624dcc5712987e7d5bb9664a5afe3f3
+EBUILD sphinx-autoapi-1.9.0.ebuild 1069 BLAKE2B 2e641b588ece7f2139ff2dba072c4b8b5226c849255f252769fb51757737fb30276d1e09a2859053cacf96ade68e9bbc35149c15b6af251d93511dfb9128d0f2 SHA512 3b20ab49dadd26ffd02eed6b64bdfe07cef9e7a7c9ac285c3b062c78eaeeead6ff9b341f7f7189f397386b7c7332066f4d370be86d9d8826d5946f73064e6867
MISC metadata.xml 769 BLAKE2B 6f85e487a2d2def289bb54a6addc2338bb8af85b323ec1c95851945f9c407ec22bfadd8079ac8b6e00cfbc85caa0e2b09d82329f1f87a365fc44b69c7bcd9a20 SHA512 68f02a5f98234c2a5cb15aa04ce90077b154a7e3a7a69dc0a1d0a6b5c7b42c60624878a7e2fff1576c8b586fc15e7ef042942274d4e8473835bb3d8bfdbd8393
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild
new file mode 100644
index 000000000000..3a7bbebfd20c
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/astroid[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+# Test requires pypi download w/ internet: https://github.com/readthedocs/sphinx-autoapi/issues/329
+EPYTEST_DESELECT=(
+ tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample-override_conf2-AutoAPI
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc