summaryrefslogtreecommitdiff
path: root/dev-python/slimit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/slimit
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/slimit')
-rw-r--r--dev-python/slimit/Manifest2
-rw-r--r--dev-python/slimit/slimit-0.8.1-r1.ebuild10
2 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/slimit/Manifest b/dev-python/slimit/Manifest
index 1b62df4b7a9e..539b5d4b6c04 100644
--- a/dev-python/slimit/Manifest
+++ b/dev-python/slimit/Manifest
@@ -1,4 +1,4 @@
AUX slimit-0.8.1-fix-python3.patch 18813 BLAKE2B d4cdfcce63635ad35ebd7c1c4a42ee9b1d4fba2dea4aac3a97274c98e012b615dbd121413243e1279c00ad731527bf311aa5fe4dc25fa174b5142abb4f990c32 SHA512 fad15e30fea0000f797db6e113ca83d847e412c5906e42d15bf1d8afab857d617403f92b733ebad761cd6182e16e5a8f21081829d2410f9842bd8fa8f093b8e8
DIST slimit-0.8.1.tar.gz 90096 BLAKE2B 9bf7a00fa7aa48a47950b2db66868c03e3923ed7b878ac4d93bd92becc1909cb79a15365db8185f6d8872028e0d01343394e4c768149155bc6aaeb4acf69954f SHA512 ce33dd15c755b8327a73121322b525738b5f8d83c08b0b6329fa6e090575c68883b4bfa29df04544e5f566f3a81a60e480b5e760e2b0e67644a7db5e25604cc0
-EBUILD slimit-0.8.1-r1.ebuild 971 BLAKE2B e12621d231fc740759ca0e3016be53ce0eae76950a863e06d1602ea3e77f130fa5d5a96670f61d4a54f7ed5294be3721c8b224f846374c1fb9aa0c3aa00a8381 SHA512 fe4f16ee9edbfdd83d30a06505e7f0a814dfdd90555ec51002b070a4ed9246e80fea88946c94d9e4c34a78084e5ba7c51e72c6dd6b938307636352f9b48dee5c
+EBUILD slimit-0.8.1-r1.ebuild 898 BLAKE2B 320e76b7d4f63da47a783ce4fafe4411a761060ddcfeacc3765f9ee66ca59c26fbe57f19f03f4bbd058693deb3bfec0934113099bb762dfd12095fd9dd1164f9 SHA512 8afc481fe2fa80962bac21cd8f2eaa2b8f68ea163e98b1fe78778d083e44fe49e7312c783ba933d9f56ef7d37c0d1c40c641e44e35dafaaaf2707c466c6eac7a
MISC metadata.xml 480 BLAKE2B b3143e1d196b7904d7e2941f230b6eb473e91a97957ecc2dd989c79272bc116d09f8c5340a267599c5f535b3376511f95a3fc34b5cfafe0924337d0df5f048f3 SHA512 25cbf46f9d6a5246e2640f173c27265d177cca27818032bd172adb353a8da175f2645ba582e0d0f5f520e3665e7d4bd9808be42effe009972817892a53138331
diff --git a/dev-python/slimit/slimit-0.8.1-r1.ebuild b/dev-python/slimit/slimit-0.8.1-r1.ebuild
index adb879571797..d402ab74e3ea 100644
--- a/dev-python/slimit/slimit-0.8.1-r1.ebuild
+++ b/dev-python/slimit/slimit-0.8.1-r1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( pypy3 python3_{7,8} )
+EAPI=7
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
DESCRIPTION="A JavaScript minifier written in Python"
@@ -34,5 +32,5 @@ python_compile() {
}
python_test() {
- pytest -vv "${BUILD_DIR}" || die "Tests failed with ${EPYTHON}"
+ epytest "${BUILD_DIR}"
}