summaryrefslogtreecommitdiff
path: root/dev-python/slimit/slimit-0.8.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/slimit/slimit-0.8.1-r1.ebuild')
-rw-r--r--dev-python/slimit/slimit-0.8.1-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/slimit/slimit-0.8.1-r1.ebuild b/dev-python/slimit/slimit-0.8.1-r1.ebuild
index adb879571797..d402ab74e3ea 100644
--- a/dev-python/slimit/slimit-0.8.1-r1.ebuild
+++ b/dev-python/slimit/slimit-0.8.1-r1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( pypy3 python3_{7,8} )
+EAPI=7
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
DESCRIPTION="A JavaScript minifier written in Python"
@@ -34,5 +32,5 @@ python_compile() {
}
python_test() {
- pytest -vv "${BUILD_DIR}" || die "Tests failed with ${EPYTHON}"
+ epytest "${BUILD_DIR}"
}