summaryrefslogtreecommitdiff
path: root/dev-python/shortuuid/shortuuid-0.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/shortuuid/shortuuid-0.4.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/shortuuid/shortuuid-0.4.3.ebuild')
-rw-r--r--dev-python/shortuuid/shortuuid-0.4.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/shortuuid/shortuuid-0.4.3.ebuild b/dev-python/shortuuid/shortuuid-0.4.3.ebuild
new file mode 100644
index 000000000000..96c28acd7b8b
--- /dev/null
+++ b/dev-python/shortuuid/shortuuid-0.4.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A generator library for concise, unambiguous and URL-safe UUIDs"
+HOMEPAGE="https://pypi.org/project/shortuuid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pep8[${PYTHON_USEDEP}] )"
+
+python_test() {
+ ${EPYTHON} ${PN}/tests.py || die "Tests failed with ${EPYTHON}"
+}