summaryrefslogtreecommitdiff
path: root/dev-python/shortuuid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/shortuuid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/shortuuid')
-rw-r--r--dev-python/shortuuid/Manifest3
-rw-r--r--dev-python/shortuuid/metadata.xml11
-rw-r--r--dev-python/shortuuid/shortuuid-0.4.3.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/shortuuid/Manifest b/dev-python/shortuuid/Manifest
new file mode 100644
index 000000000000..44c3f5911710
--- /dev/null
+++ b/dev-python/shortuuid/Manifest
@@ -0,0 +1,3 @@
+DIST shortuuid-0.4.3.tar.gz 6096 BLAKE2B f658bed1ba10b6a18508834e27c4a9a6a9d080c7a6c2a75413bb2b22a71b339ef66b73b8f99436c609b00ecdc1d38b691e2eba32b5c34ea83d4c8191275aa0f4 SHA512 409bcaaff421a392640e39a7d25d4eaa320826971dca9d13270b61f21c78f65c617c302b3f7db5d0a3400c8ed4380a3a8eda90d1e9ad13d0a3a7eca53440ea7e
+EBUILD shortuuid-0.4.3.ebuild 596 BLAKE2B 8b522a46181c926a05a22df666e41bf7fbb1561833b27c43e601ac17f3aaf9057c87350004e3ccd589b09c2a60051871a4f5c51206612c6338605ad198b193b9 SHA512 95d801871dc1ab4594c342472ba54287dc73658b9cbb318b3e7e2088997a2c492a1791e8b6c5f1dfe5298e2cbaf592655751d19042c3492a2dffb3beae97320d
+MISC metadata.xml 599 BLAKE2B a3cd639ce610b8469b6e56cefc9a6bcd0d0a5c86e8c447e97bdb38a24e55bbd2eaada7b7b6c6671c4ceba3f46b1eb636b43ed2517f0f18c1e832e21add40c5e8 SHA512 5698091a4834b25b32040d0cbe4a2eb6b6341312866eec765239abaa3a242104a8ceec0e20b780ad47d3acd04573699d9955c61b01fc6e5b54d9a7d3162a663e
diff --git a/dev-python/shortuuid/metadata.xml b/dev-python/shortuuid/metadata.xml
new file mode 100644
index 000000000000..3c92e94f4a85
--- /dev/null
+++ b/dev-python/shortuuid/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>A library that generates short, pretty, unambiguous unique IDs by using an extensive, case-sensitive alphabet and omitting similar-looking letters and numbers.</longdescription>
+ <upstream>
+ <remote-id type="pypi">shortuuid</remote-id>
+ <remote-id type="github">stochastic-technologies/shortuuid</remote-id>
+ <bugs-to>https://github.com/stochastic-technologies/shortuuid/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/shortuuid/shortuuid-0.4.3.ebuild b/dev-python/shortuuid/shortuuid-0.4.3.ebuild
new file mode 100644
index 000000000000..96c28acd7b8b
--- /dev/null
+++ b/dev-python/shortuuid/shortuuid-0.4.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A generator library for concise, unambiguous and URL-safe UUIDs"
+HOMEPAGE="https://pypi.org/project/shortuuid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pep8[${PYTHON_USEDEP}] )"
+
+python_test() {
+ ${EPYTHON} ${PN}/tests.py || die "Tests failed with ${EPYTHON}"
+}