summaryrefslogtreecommitdiff
path: root/dev-python/pyxattr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
commit5a1fb66df455454109e1de61d38b48f509dc68b8 (patch)
tree0213f12db1b0138bffda43d11208c5d701967638 /dev-python/pyxattr
parent3a8423ee2874c2fd96358b28af08d38d83e9bdc0 (diff)
gentoo auto-resync : 18:04:2023 - 05:54:20
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/Manifest2
-rw-r--r--dev-python/pyxattr/pyxattr-0.8.1.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyxattr/Manifest b/dev-python/pyxattr/Manifest
index a042accfdc89..b38a22a80ab3 100644
--- a/dev-python/pyxattr/Manifest
+++ b/dev-python/pyxattr/Manifest
@@ -1,3 +1,5 @@
DIST pyxattr-0.8.0.tar.gz 35720 BLAKE2B 776cacc68a2dc3e9d60b026d9d0dd3b3ff362445c8f9eb205d1799378b1cb1ab0e6af5fe9bc4f295e428195d0431287f62f6fb735a37831e3b36b7f53f5535a6 SHA512 921af6341cdfdfccea0c46e02742d051de00c7eca75c52f9fcc1618217c41869da957dd6ce03fa7d1367b86b44b49b5263ba65de277bf2453807c6f69a67141b
+DIST pyxattr-0.8.1.tar.gz 38443 BLAKE2B 2b044f5774c4b1e95a711e3bdad0c2f604d330865155360b8b6e08377c78d058e17a7d3f4792d6ef932b81f92b1671277663a36652d60a25aaa658a2e545f8a6 SHA512 98ba196b29b431ecacf0257712aa219175ba030e1c62fb388b4f3109d2d6b14ef09ed38f85177bd2991d3109c0af4cd2a108d17886dd51549e817727714f72f1
EBUILD pyxattr-0.8.0.ebuild 848 BLAKE2B 22d5c770071640de8e5f8b0cedfd62e7403195cf7163adac7a2d09bd1308b05d0828a9d457d4e949bab0d56335a2dcb6261cd3f0772a517937f8bd3f283ae2d2 SHA512 72eff4197c2b0c84dc9ac7fd238bfeb9a1c94acf4551d83822ca72563413009731bd8b65547c113763aee71296ae33f951f95047bc1ce7760816fdcbe1f21295
+EBUILD pyxattr-0.8.1.ebuild 855 BLAKE2B 6e1d51e5ef69f0cc0af624ab6d88c99785f66e68ef2f52e1333b34808df6182b2c7618281674d459fd86c33f807622682bf67ea09364d21c8efcf0299459d86f SHA512 9857c418186e79c0191e94033a3091e3ffe331f7ef639717064369f1e82032c4fd7dc2859d4a461db43f6c853a11278ede6ba8a3b655f0b289e5bfb0ee850de2
MISC metadata.xml 668 BLAKE2B 4464bbef18d4eedbc1309c009e0679ae4a6a5870416802e4ad7bdd3814ec1cc1f741386c1bb44578e5ae67c6da978645a5a14c14e74e58ac928708bbf09f5a4a SHA512 7efd22b5b2a920c4725558bce7ca44dd84106001e716188b28eedc7f4718d28b542f647fe8d9e0b58ec9037461745df323589f187933ea73947e6c9e5b59ede8
diff --git a/dev-python/pyxattr/pyxattr-0.8.1.ebuild b/dev-python/pyxattr/pyxattr-0.8.1.ebuild
new file mode 100644
index 000000000000..e9891b221530
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.8.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="
+ https://pyxattr.k1024.org/
+ https://github.com/iustin/pyxattr/
+ https://pypi.org/project/pyxattr/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ sys-apps/attr:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/recommonmark
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+ # Bug 548486
+ sed -e "s:html_theme = 'default':html_theme = 'classic':" \
+ -i doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}