summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
commit5a1fb66df455454109e1de61d38b48f509dc68b8 (patch)
tree0213f12db1b0138bffda43d11208c5d701967638 /dev-python
parent3a8423ee2874c2fd96358b28af08d38d83e9bdc0 (diff)
gentoo auto-resync : 18:04:2023 - 05:54:20
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin258611 -> 258596 bytes
-rw-r--r--dev-python/aiosqlite/Manifest2
-rw-r--r--dev-python/aiosqlite/aiosqlite-0.19.0.ebuild26
-rw-r--r--dev-python/boto3/Manifest2
-rw-r--r--dev-python/boto3/boto3-1.26.115.ebuild66
-rw-r--r--dev-python/botocore/Manifest2
-rw-r--r--dev-python/botocore/botocore-1.29.115.ebuild72
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.77.1.ebuild64
-rw-r--r--dev-python/pyamg/Manifest2
-rw-r--r--dev-python/pyamg/pyamg-5.0.0.ebuild49
-rw-r--r--dev-python/pyxattr/Manifest2
-rw-r--r--dev-python/pyxattr/pyxattr-0.8.1.ebuild39
13 files changed, 328 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index d812463e868f..e2796ed7b385 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/aiosqlite/Manifest b/dev-python/aiosqlite/Manifest
index a0eb80091516..8b1216886f69 100644
--- a/dev-python/aiosqlite/Manifest
+++ b/dev-python/aiosqlite/Manifest
@@ -1,3 +1,5 @@
DIST aiosqlite-0.18.0.tar.gz 27066 BLAKE2B 2743db7770b8377a1ab2b11b286684840b1ace9015180fb18590026e4607f78f72068765ea5ab69f9b2fd6ad96007dbbb517d371c2142930f2a587f0b13f81ea SHA512 dcab1bac1b32a86f31957a2f297969ba25cf43cd129afba5810812124964640744cdcbf9764c0037adb9b6cd917cd816a26823578ffb16d864be19f92373d59f
+DIST aiosqlite-0.19.0.tar.gz 21832 BLAKE2B 0cd367979e84af23e7ca9965535ab6477bb78c6b2b0c6af3a8698bbde6400dee80d468b99f125ae03ab98053212170cbbaaeac5134e9f85dc66704eafa96f78f SHA512 56debffdb73b6ec98bb69ce2b711e53417cbcb06501a2dc94558157c2cd010f9f56345bcf5378a17eb064ac6bd5f3638650edffcd1f73883bdeae7476afa96e8
EBUILD aiosqlite-0.18.0.ebuild 589 BLAKE2B fcebd5cfab90d4b98a35f68b9e111addcc4182bcbc7378358903c70879fde6d3bb2709826110e65c310804ab3f39ee65b44152132d6bba88b2f4ca533ffbf209 SHA512 10aa33117de0fd2940227e9c8e0e45a07e8cdc7ffed02630713cd0810e39e82b909f76d0a1e7456bbdca1caa5eb951a1610fc781a51298e7283c71a6b1639596
+EBUILD aiosqlite-0.19.0.ebuild 590 BLAKE2B 469bcc1be099fa2bece4cc337c98815e564c3475854a319e667ab6e18af6dc672c730c7cb78245afaeffd332cb2493f8275779562fc275060e9704848976d02d SHA512 dd08db26b702ddb80a56b06ef36f5aed68926dbb73ee5759432302ed4249ee90686212771aa2c675678db26edc0062acfb8f55c6fd433e7da30a7e077ed910c5
MISC metadata.xml 433 BLAKE2B bff5372449e51d02ca3946ee993b58cf9243bcd7fb13e8403a45e203085e100a3a15b655b1ec75c182106790fe94e0afe20740db5ea214ef12a5d411bb859693 SHA512 32f0a358ac4ee6fb02cecec77e8920a19056538a6ff84f0fbed19e4d2146a1fcbcbd0faa36a07ba16eda9e89ebaf83643127482f00394baaefe90c0bddc69563
diff --git a/dev-python/aiosqlite/aiosqlite-0.19.0.ebuild b/dev-python/aiosqlite/aiosqlite-0.19.0.ebuild
new file mode 100644
index 000000000000..bef55760e148
--- /dev/null
+++ b/dev-python/aiosqlite/aiosqlite-0.19.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="asyncio bridge to the standard sqlite3 module"
+HOMEPAGE="
+ https://aiosqlite.omnilib.dev
+ https://pypi.org/project/aiosqlite/
+ https://github.com/omnilib/aiosqlite
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest
+
+# AttributeError: 'str' object has no attribute 'supported'
+#distutils_enable_sphinx docs dev-python/m2r
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 27c71b957de4..a91cbd07c36f 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,10 +3,12 @@ DIST boto3-1.26.109.gh.tar.gz 635150 BLAKE2B d60417a5220eb1cd4a82e9652a0c6bc2bdb
DIST boto3-1.26.112.gh.tar.gz 636498 BLAKE2B 2768bdc1fec35eca4a3079bf12933fc28322d111c8be4548d7c5068597e5020c02a1036124088e158a24b6eec705152dcfa36f4029ee1e64ff9cf429cecee7d3 SHA512 f125f8951f2d8703b1e8c1f2f617ba77e190a3dd7fdb04b04a7fe36b56dabdcc3939d9ccda6127ce08d41bcb3573fb94a86dc4f8cfe61435414c8671786c6f36
DIST boto3-1.26.113.gh.tar.gz 636722 BLAKE2B 0b5c3819c004ba425294208f114b4b11713730a18e45cf274b8bfe1f762f59e2c404e0a4ccbbec16be934931e7b37c2bd462b7df7d6d47275b1de26300de216e SHA512 bafda63eddb19b97538224e9c12bc3178a0999cc4d2547cb7ec7335f28a7fe3875130573d4fab2fe21000cc1e3bc4e3a7a5ae99bc8f0e9dc7e2b40ad6fb5a2e0
DIST boto3-1.26.114.gh.tar.gz 637000 BLAKE2B 06f74ac214f4c2161ebe464e1c8fc42c74cb4429110c8ce979db3962fde5240c62ac94b4b9ca002fff89a36659a8830265ac693bd9522082b8cae21108e16cf9 SHA512 324ea177c8ee98a0935d1935f08b31f1640eedf8a7dd19f2bc958f6c1c2fb9deea29f0482b1f4c903d70860a93274dd0d70eafe0564116361daf5e7df51abd26
+DIST boto3-1.26.115.gh.tar.gz 637877 BLAKE2B 861cf3a197002bcfac3f1ca3428bd01f1a8e103462e0de83ed33bb7575de0056f4222195c70dcd0e40dcf3744467e8c017bfe361e589eaf641fec76d6d3eea94 SHA512 337e90d91bb9efcff89b410d5222dead7ce1d0f35257bebe0309cd5fa657facd1a0352bee0ea23d3b94ad852da03a182b7dabf4c2d854390fd227bd58fabc6d3
EBUILD boto3-1.26.104.ebuild 1508 BLAKE2B 42be8b915da646a7afe6dfc988542d3d79b5dbdc565d2e738d210e3f77b7c5ba6dfbac45e46b9cc3cc4770611cbc0c155abc7f1807ff0cb8e6033f927bea4048 SHA512 06404c0363c0c7c0d378d1c2b91073c137a1685d2d846d98c655e6d001df5cde0eb51bf6e160879af2b56321a02e84146ce634855f70c7c3fbbd1adbb9b8ef8e
EBUILD boto3-1.26.109.ebuild 1515 BLAKE2B 611fec92e11c2c75d95e39043931611ad3396698f6868ff4b60391eb8353e71a824613ab8a1dc96c9640cc2f933ba761c47628acf7be917abe0039628b38a071 SHA512 475e2648fea04db00eb4fd70e48a7599c758cf8e225caa6250b222293bd9aa662d962c6d6db730040680256e61131301571675f3e1470735217f950abf2c3497
EBUILD boto3-1.26.112.ebuild 1515 BLAKE2B 611fec92e11c2c75d95e39043931611ad3396698f6868ff4b60391eb8353e71a824613ab8a1dc96c9640cc2f933ba761c47628acf7be917abe0039628b38a071 SHA512 475e2648fea04db00eb4fd70e48a7599c758cf8e225caa6250b222293bd9aa662d962c6d6db730040680256e61131301571675f3e1470735217f950abf2c3497
EBUILD boto3-1.26.113.ebuild 1515 BLAKE2B 611fec92e11c2c75d95e39043931611ad3396698f6868ff4b60391eb8353e71a824613ab8a1dc96c9640cc2f933ba761c47628acf7be917abe0039628b38a071 SHA512 475e2648fea04db00eb4fd70e48a7599c758cf8e225caa6250b222293bd9aa662d962c6d6db730040680256e61131301571675f3e1470735217f950abf2c3497
EBUILD boto3-1.26.114.ebuild 1515 BLAKE2B 611fec92e11c2c75d95e39043931611ad3396698f6868ff4b60391eb8353e71a824613ab8a1dc96c9640cc2f933ba761c47628acf7be917abe0039628b38a071 SHA512 475e2648fea04db00eb4fd70e48a7599c758cf8e225caa6250b222293bd9aa662d962c6d6db730040680256e61131301571675f3e1470735217f950abf2c3497
+EBUILD boto3-1.26.115.ebuild 1515 BLAKE2B 611fec92e11c2c75d95e39043931611ad3396698f6868ff4b60391eb8353e71a824613ab8a1dc96c9640cc2f933ba761c47628acf7be917abe0039628b38a071 SHA512 475e2648fea04db00eb4fd70e48a7599c758cf8e225caa6250b222293bd9aa662d962c6d6db730040680256e61131301571675f3e1470735217f950abf2c3497
EBUILD boto3-9999.ebuild 1514 BLAKE2B 5d31d27ac50ed037fb8be61559bac03bd2a8c63f3220ac93ecc864c0e3cbd34763b9b70761a9f364cbc85a0edd84c6f6eeff614292f31473b4935e5bb86fae7b SHA512 26bd2959c745f0e423d683d2fedeab9a438d215fa9b28b403d0cea81caac7436f05382b2a91a183bc1095f3b205e3b2115f931cd7803e0b9838c2a507562da5c
MISC metadata.xml 493 BLAKE2B 7d6324fc877ffe1d20c5369c2af0b09a7028f94d28f1841188913d0d8be7ea699c9d3f92c624992c4c96bd69615d3a1211a2483c76c56b7d3082492e43512523 SHA512 44420d8c03d5986f990b76369edfa8dfd7659b4952db3ad946fd05392ec594628a28745ad888d055d4f074d5214f61fcffafe6c04c4ab54109d45ac0371582bd
diff --git a/dev-python/boto3/boto3-1.26.115.ebuild b/dev-python/boto3/boto3-1.26.115.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.115.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 9e09e4dc3c70..fdb670e0cea0 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,10 +3,12 @@ DIST botocore-1.29.109.gh.tar.gz 11375235 BLAKE2B 9bd6333319cce685257a5bd4eb06d2
DIST botocore-1.29.112.gh.tar.gz 11380151 BLAKE2B 0392abe4e6be29a9e3eae1e693d7cc121ffd2bba08ac3555b22bb234f6c94cda90251f51368774f7d02a06eb16c9f80c703280947e308390374da2f60efedeb4 SHA512 7f2445db878ea21562604ae57722fd993fe5f9770990ee27f98dba440617505f5e14f3f13a4e97e8de0927a8f5aa384fd7f1355ad3d669264e7eb48fc19c93d2
DIST botocore-1.29.113.gh.tar.gz 11386284 BLAKE2B a3611f356f25080f00f675b20a8b49952bcf1e464b9a114bf37392ebdf4573ac1e9eb6373c61dbf87f8101e055f4f6600f7825f45b00c5723c1528d74865dd6c SHA512 8a16fdde7099ae75a3587ee0c0108c12a6c5c27dbbbfc2d98eb3ccd4c66b45f0389a722f1b10ac3f3cc69ea7ba9135cc0604e35126cc2691a26f4a6173d5258a
DIST botocore-1.29.114.gh.tar.gz 11388772 BLAKE2B 6c9ce892cccf2f85ba4bcd49b31309528016313bb699efbca3b00d3cf3797de5e1b35bd71a3b5bd6d471e9c411ad7750ebd25c03571aa18c34cd42bc2f47bc19 SHA512 6633a2aaf2865a89976ba4097fa64cee4167a9144d4eadc7d9be711e65735bab08d2c03c18ae52c4901fea47265301cb95c91306b261fb48b4119bec66cde376
+DIST botocore-1.29.115.gh.tar.gz 11394187 BLAKE2B 621be4a22b7f06d520bcd630ed6e1a8721d11d5c7822f56f54907177d0773b69247b627a42cfbb1b8e053f54ea16f7238acc0d485379c1e071b6e917ea625596 SHA512 525d8f219cad541c4cc125c2d5eeb7595fba6192bda23e7bcc02a65e4ec413756ae3d8ab5bcb3185b5c837bc7214c22146e52716ff010cc396bc8d32cd98b956
EBUILD botocore-1.29.104.ebuild 1827 BLAKE2B d9e353ffebf3b77bdb5b034da339f9f3cf95937e288fa522fcc40f88a4752c58ae085406bfefa595c3738ec118712cdb4ee0509c1dee7a00e2c76cd2a657009c SHA512 f0d3e81726bd65bf4c097b63e8673881949970e29d976de53c1facbccf8cd1d214fea9153f4820a5889f1892979342a0255e110b243ba613d4e803a940d46602
EBUILD botocore-1.29.109.ebuild 1834 BLAKE2B 50305f707e533627ed4b906b3c5845a931f825049d40d8e9d9eedf1323d130634b578f68adb046db30e3e9a4168361da69d99471a7b744407dc103130a114994 SHA512 45952178574e99269d9767374818d867bfcc47ebf0f4c37dbab6cf50089577badb69967bd06b0b2d10b15dcd1c3e8b82adac88404d7c3b7d7784292b4005e797
EBUILD botocore-1.29.112.ebuild 1834 BLAKE2B 50305f707e533627ed4b906b3c5845a931f825049d40d8e9d9eedf1323d130634b578f68adb046db30e3e9a4168361da69d99471a7b744407dc103130a114994 SHA512 45952178574e99269d9767374818d867bfcc47ebf0f4c37dbab6cf50089577badb69967bd06b0b2d10b15dcd1c3e8b82adac88404d7c3b7d7784292b4005e797
EBUILD botocore-1.29.113.ebuild 1834 BLAKE2B 50305f707e533627ed4b906b3c5845a931f825049d40d8e9d9eedf1323d130634b578f68adb046db30e3e9a4168361da69d99471a7b744407dc103130a114994 SHA512 45952178574e99269d9767374818d867bfcc47ebf0f4c37dbab6cf50089577badb69967bd06b0b2d10b15dcd1c3e8b82adac88404d7c3b7d7784292b4005e797
EBUILD botocore-1.29.114.ebuild 1834 BLAKE2B 50305f707e533627ed4b906b3c5845a931f825049d40d8e9d9eedf1323d130634b578f68adb046db30e3e9a4168361da69d99471a7b744407dc103130a114994 SHA512 45952178574e99269d9767374818d867bfcc47ebf0f4c37dbab6cf50089577badb69967bd06b0b2d10b15dcd1c3e8b82adac88404d7c3b7d7784292b4005e797
+EBUILD botocore-1.29.115.ebuild 1834 BLAKE2B 50305f707e533627ed4b906b3c5845a931f825049d40d8e9d9eedf1323d130634b578f68adb046db30e3e9a4168361da69d99471a7b744407dc103130a114994 SHA512 45952178574e99269d9767374818d867bfcc47ebf0f4c37dbab6cf50089577badb69967bd06b0b2d10b15dcd1c3e8b82adac88404d7c3b7d7784292b4005e797
EBUILD botocore-9999.ebuild 1736 BLAKE2B 6ca7ea14855f5f8db2d166ba1f29835d4c994a0a8fa38f3852406289a4465c091909562ac678f1c0bf7e640a594731b0d4319efc0f34f6bc640fbae06746c4bc SHA512 f891bf0eded88d9af3b87fc7c9ee4c6a129d263e672821f3b9654d43bb3bcac41305b834192088d15b50f3f9d36ea95374180cf13e1cb67149595ec63e4cc155
MISC metadata.xml 499 BLAKE2B e5aaa7da26f200c09adfdf38b68f656bbccbec627cb5d966b280ac2165334e7eec659c89075bcace748f58e2ec3e7d2998e54a688d56ecea2d30653c67dfd35a SHA512 103c554d5dbd967bf9b6e418b3913d9235e7e910d012160909ce0715134ed2e37b06e6a345395f9d16ce08d1cf51f3ce458bce93c6a978fd3dca6610f2acdbd0
diff --git a/dev-python/botocore/botocore-1.29.115.ebuild b/dev-python/botocore/botocore-1.29.115.ebuild
new file mode 100644
index 000000000000..491b6bbc21f2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.115.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 2832fac3b77a..d3541f511a58 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -3,9 +3,11 @@ DIST cfn-lint-0.75.1.gh.tar.gz 3487870 BLAKE2B 26aaf3b24023260d7a7d8f2b89fc9135e
DIST cfn-lint-0.76.1.gh.tar.gz 3631194 BLAKE2B 95d395369fc230fe4e6c5d5e2a0e4bf246f1f312c6595e998004d43a7662e43ed0612a56893956fbb15e99ed197d9af2723fc1c2ea9b14fc27d8b4ff7b29e484 SHA512 5c65111fa7f57b268f2f3f52157d464de467cfdf16cd672e399ab7b2d23d648346c6754c45cd169f993ae15180ffafc710c9f2fa0675a7ecb1d8fc5b3d0ec5ce
DIST cfn-lint-0.76.2.tar.gz 3402554 BLAKE2B e5f9405d2852e3b81140a24d94c90a3bf8c919eb6823280a0a887c6acc56ec71d991cbc76532cc49d1189a8f64750ba3e9db02fb3b46b27a28ec3468f4dd268e SHA512 96351ade16308be18baace1351e263a179eacc0b3635e9baa959baadaebb6a08825f6cb9cd83cb83b8635785c7f54405bfcf00f85d6d95d101d3298919cd1ea7
DIST cfn-lint-0.77.0.tar.gz 3474124 BLAKE2B 5715618f6b44a7a88ef3af8d21d038fa4ce4707973e64eb9712ff524cd5276e71802ad4b9a55580ac469b6474c7d48a8ccee04660bcaf7934df7a23cab1e5a9a SHA512 6509197ef29d8bcbfc416df0a63f89736f704b147bbeb489586b6a06e1818f1d91e59429c73a9e9e23dadb20325a3c79d0b8e1b4637cd0e131f9673422e36734
+DIST cfn-lint-0.77.1.tar.gz 3483399 BLAKE2B 6eaaba9cf70044c673164bce3a062b00ae7703b091e2c0e8d5065e815278fdb88d75f2592695cd1be1612421f95c806f6eaf3be9f4725abec0cf5e39070ff175 SHA512 0d18e7bc19d5562c88194f834267fa6d2fd8125754399ef281598beb68752e7935a653fbe3a0573f4887cb7a76c41b49ad8e268d390db59dd79794cde4939f31
EBUILD cfn-lint-0.74.3.ebuild 1623 BLAKE2B 07a514b96d3f3b0084e82698f7c50c57d7c592573c964aa5cad35681347b31035bac3ba580764b5538bf71b35622fd697e782162fb4796cb60afb69d8f3bf11f SHA512 5b8ae5749d2bcf6faa296cb046185888b6e42213341d990839a3de496b0cd3dce699a0a7fd318537b9405a5a6b7a2104ea7b40adfbdf1f4f63721a28e32a5988
EBUILD cfn-lint-0.75.1.ebuild 1625 BLAKE2B 22541f210143e50b731ad2234f300f8175a3626288cb0d8358e6d690d81a56eac4c34521c5ea0468e6fef9a95e4c0bbbba1d8792c1e8490c4b787413730088e7 SHA512 4a2d0db8bc62e0041ee27fc776e3a75e7839333ff3c58affd65128a45e615ba2037d8b819972d584f67afcd18a5b85f2c4ff8c46b32676b6db70c81f6cd347ef
EBUILD cfn-lint-0.76.1.ebuild 2157 BLAKE2B 57d16cabb2460f7161933f9ca3814baccad5e3c0ebedc0332e07574db35c4432a916415fba17e063da1d71f09436663450b0ab42d19eefcf16c7b24f940fe71f SHA512 511eecc772689a9e13a80070c96670ac0b45bc207ca90b228e8b0acd36c73cc9df7a33ff4714512f59e0221e36be9ba3099c1711402bc39eacd5e0a7415d7b92
EBUILD cfn-lint-0.76.2.ebuild 1977 BLAKE2B eb75179972626397fd5d225f0f228a69eee61257c23bc63685a96e495183b733ec146fad85ca4e821fe6f1cfbe55b079329a4d52fb83f0391f74cd124a6637f2 SHA512 656b2acf67cb7944a727297cd6df99cc9640177304661b9626d075499b50d60b7941ac3473430cc2f9fda1b19b693a056d52da6198b2b73e4eac634070a794da
EBUILD cfn-lint-0.77.0.ebuild 2013 BLAKE2B e685a47e788380adf32a251c55c6fbe770afbc84b493da3accec08e3227435425c424cabe0f46c9e7660829bc6cd6ee8408eeb4df64a143312a3b244e21a5b41 SHA512 0d6a0021003a3f905f1d31545ad66438d4540f3ad4bad8b094c8bb1fcc4d125266fdf12d6a67fae2281dcf7886e003295697c081240617b714f014f1e2e995e1
+EBUILD cfn-lint-0.77.1.ebuild 2013 BLAKE2B e685a47e788380adf32a251c55c6fbe770afbc84b493da3accec08e3227435425c424cabe0f46c9e7660829bc6cd6ee8408eeb4df64a143312a3b244e21a5b41 SHA512 0d6a0021003a3f905f1d31545ad66438d4540f3ad4bad8b094c8bb1fcc4d125266fdf12d6a67fae2281dcf7886e003295697c081240617b714f014f1e2e995e1
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.77.1.ebuild b/dev-python/cfn-lint/cfn-lint-0.77.1.ebuild
new file mode 100644
index 000000000000..2b6753f1c840
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.77.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.64.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/dev-python/pyamg/Manifest b/dev-python/pyamg/Manifest
index b896c7983488..4d73dfe33c5e 100644
--- a/dev-python/pyamg/Manifest
+++ b/dev-python/pyamg/Manifest
@@ -1,3 +1,5 @@
DIST pyamg-4.2.3.gh.tar.gz 4101959 BLAKE2B 190cce0bb06bbfc09e8c7a8d6d70498308e4d0e098c23a12d12ae8373b56ef183694430c1f85e287682f9733e3f85ff2bd94d8e10003f578af32f3c3f583a8f4 SHA512 ad11ed2870de41bb9596167a5a7fc3edd4c4bc898c2f5b5ffa3cfa862372d993fe1adfc5f3d199150ba69a4d2acbf75e5d99b3aa872273da0d05f1fd8d9f5c6d
+DIST pyamg-5.0.0.gh.tar.gz 4132243 BLAKE2B 72630feb399653566c32ece3aad52f7e7634418c607ff8a4cc84aa1f5a378ef27b0b954e2ed1e52a9cb74a26a3b0c30ca3b0c25469ad4a7001dd5dc0b6a2a535 SHA512 c601e93dbc805f56aa976e5e32c80ae8307022736f29d1d28c5646e814d0c3684b1241f0d8953a2c47ba372107c013e9421d49997340887c0dc92d7c0a56dea7
EBUILD pyamg-4.2.3.ebuild 777 BLAKE2B 3c54988e6b94f11c50d85330ba836d2b55ba3184291b536ff8fb62198d57086a218b0949ff2bc79ab655972203a799afed8e5e6e2ccdfe07c6a89ccb51f640b6 SHA512 c788a848bb6ebf0171747bfaab6c75d2ae998afd61054a5677471ae8ed74e45b8d6161211601f104c9d561071543ea0e476eb7c7b4954960df147aba90a0fcec
+EBUILD pyamg-5.0.0.ebuild 961 BLAKE2B 75bcc3ff66875feaa2b9c28a61236fdd5a5c97a795c71c794dabc95477763c9b96a6d4824512c63cd18d8c453405e904b25e73ed7e5c35c87a59a8a66a6e4db0 SHA512 688959aeca2d634c2ed2e88989464bd37fab736bb9de93da15b3797a9005b99e77910ec9ec1b3e2d1ba5a9cbbb35546f7e09ecb7d44c8ab068b26d6ab94b04c8
MISC metadata.xml 768 BLAKE2B 26229e93507c2f6ee26cf2f079b9e9591bd9e4b0f7922ae231444f885afc4a3050b4175a948b81260d5b50d2b30e608a65c220fa0c1e7a5fb8c3e7816f81e610 SHA512 f7f5876fbfc7a8057edd3c0f1bde6721721408a2def54cad978ca4a3699a1bf9c75a7b690c89e74a82a325a368d884e8f232a64385026dda267abf8898124b33
diff --git a/dev-python/pyamg/pyamg-5.0.0.ebuild b/dev-python/pyamg/pyamg-5.0.0.ebuild
new file mode 100644
index 000000000000..4171b0ddd8fe
--- /dev/null
+++ b/dev-python/pyamg/pyamg-5.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="
+ https://www.pyamg.org/
+ https://github.com/pyamg/pyamg/
+ https://pypi.org/project/pyamg/
+"
+SRC_URI="
+ https://github.com/pyamg/pyamg/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/CppHeaderParser[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs pyamg
+}
diff --git a/dev-python/pyxattr/Manifest b/dev-python/pyxattr/Manifest
index a042accfdc89..b38a22a80ab3 100644
--- a/dev-python/pyxattr/Manifest
+++ b/dev-python/pyxattr/Manifest
@@ -1,3 +1,5 @@
DIST pyxattr-0.8.0.tar.gz 35720 BLAKE2B 776cacc68a2dc3e9d60b026d9d0dd3b3ff362445c8f9eb205d1799378b1cb1ab0e6af5fe9bc4f295e428195d0431287f62f6fb735a37831e3b36b7f53f5535a6 SHA512 921af6341cdfdfccea0c46e02742d051de00c7eca75c52f9fcc1618217c41869da957dd6ce03fa7d1367b86b44b49b5263ba65de277bf2453807c6f69a67141b
+DIST pyxattr-0.8.1.tar.gz 38443 BLAKE2B 2b044f5774c4b1e95a711e3bdad0c2f604d330865155360b8b6e08377c78d058e17a7d3f4792d6ef932b81f92b1671277663a36652d60a25aaa658a2e545f8a6 SHA512 98ba196b29b431ecacf0257712aa219175ba030e1c62fb388b4f3109d2d6b14ef09ed38f85177bd2991d3109c0af4cd2a108d17886dd51549e817727714f72f1
EBUILD pyxattr-0.8.0.ebuild 848 BLAKE2B 22d5c770071640de8e5f8b0cedfd62e7403195cf7163adac7a2d09bd1308b05d0828a9d457d4e949bab0d56335a2dcb6261cd3f0772a517937f8bd3f283ae2d2 SHA512 72eff4197c2b0c84dc9ac7fd238bfeb9a1c94acf4551d83822ca72563413009731bd8b65547c113763aee71296ae33f951f95047bc1ce7760816fdcbe1f21295
+EBUILD pyxattr-0.8.1.ebuild 855 BLAKE2B 6e1d51e5ef69f0cc0af624ab6d88c99785f66e68ef2f52e1333b34808df6182b2c7618281674d459fd86c33f807622682bf67ea09364d21c8efcf0299459d86f SHA512 9857c418186e79c0191e94033a3091e3ffe331f7ef639717064369f1e82032c4fd7dc2859d4a461db43f6c853a11278ede6ba8a3b655f0b289e5bfb0ee850de2
MISC metadata.xml 668 BLAKE2B 4464bbef18d4eedbc1309c009e0679ae4a6a5870416802e4ad7bdd3814ec1cc1f741386c1bb44578e5ae67c6da978645a5a14c14e74e58ac928708bbf09f5a4a SHA512 7efd22b5b2a920c4725558bce7ca44dd84106001e716188b28eedc7f4718d28b542f647fe8d9e0b58ec9037461745df323589f187933ea73947e6c9e5b59ede8
diff --git a/dev-python/pyxattr/pyxattr-0.8.1.ebuild b/dev-python/pyxattr/pyxattr-0.8.1.ebuild
new file mode 100644
index 000000000000..e9891b221530
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.8.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="
+ https://pyxattr.k1024.org/
+ https://github.com/iustin/pyxattr/
+ https://pypi.org/project/pyxattr/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ sys-apps/attr:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/recommonmark
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+ # Bug 548486
+ sed -e "s:html_theme = 'default':html_theme = 'classic':" \
+ -i doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}