summaryrefslogtreecommitdiff
path: root/dev-python/pythonfinder/pythonfinder-2.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
commit0fcaac21e786bd7911b1e8f436cd885c5e2f6437 (patch)
treeba392915815492b0ce486fc0e3ad5afb4a849b6f /dev-python/pythonfinder/pythonfinder-2.0.5.ebuild
parente30edd47e1804bf3ed1ea7be2eac67f4b8cd9f38 (diff)
gentoo auto-resync : 27:10:2023 - 08:42:41
Diffstat (limited to 'dev-python/pythonfinder/pythonfinder-2.0.5.ebuild')
-rw-r--r--dev-python/pythonfinder/pythonfinder-2.0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pythonfinder/pythonfinder-2.0.5.ebuild b/dev-python/pythonfinder/pythonfinder-2.0.5.ebuild
new file mode 100644
index 000000000000..9c74fb3a81be
--- /dev/null
+++ b/dev-python/pythonfinder/pythonfinder-2.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PythonFinder: Cross Platform Search Tool for Finding Pythons"
+HOMEPAGE="
+ https://github.com/sarugaku/pythonfinder
+ https://pypi.org/project/pythonfinder/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}/2.0.5-fix-import-cached-property.patch"
+)
+
+RDEPEND="
+ <dev-python/pydantic-2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest