summaryrefslogtreecommitdiff
path: root/dev-python/pythonfinder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
commit0fcaac21e786bd7911b1e8f436cd885c5e2f6437 (patch)
treeba392915815492b0ce486fc0e3ad5afb4a849b6f /dev-python/pythonfinder
parente30edd47e1804bf3ed1ea7be2eac67f4b8cd9f38 (diff)
gentoo auto-resync : 27:10:2023 - 08:42:41
Diffstat (limited to 'dev-python/pythonfinder')
-rw-r--r--dev-python/pythonfinder/Manifest4
-rw-r--r--dev-python/pythonfinder/files/2.0.5-fix-import-cached-property.patch13
-rw-r--r--dev-python/pythonfinder/metadata.xml17
-rw-r--r--dev-python/pythonfinder/pythonfinder-2.0.5.ebuild29
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pythonfinder/Manifest b/dev-python/pythonfinder/Manifest
new file mode 100644
index 000000000000..6fa5b636e74b
--- /dev/null
+++ b/dev-python/pythonfinder/Manifest
@@ -0,0 +1,4 @@
+AUX 2.0.5-fix-import-cached-property.patch 400 BLAKE2B 45f4cdab70100af434a4dc1df5b170ad13dafc915ab86db3b3ec1b5f617a8e926c1173d260bff4dd6553e4a9c289bff449a581add8d2b511b425135a342d0af7 SHA512 126230b303fbc083697a5f44ccdf45273a63e4f8652a997539ca3e1b48ad8a29921dcad9c30e9349ba3a58ec8dfa06a9c8c46ebd5ca53a46420ae8cc6ab2dedf
+DIST pythonfinder-2.0.5.tar.gz 718776 BLAKE2B 32a49dbff143042554d5328b61b612e3bde7a870d53a229303b6bdd2c2ce76457bf6aadcdb215efa332407003c1319215292f3278a2808b669b5b7819af08902 SHA512 4d205c66d7ae36f4f2b8ddab9cce00f4efd5548a41d251470a515b88f8be2dcede75372b9301223822031ae663c6ccf77156531b0dd5d8972424f90641255c5b
+EBUILD pythonfinder-2.0.5.ebuild 579 BLAKE2B 702f71d33e0f2a6d72cf3b2ba4c1ef78891d6d6b608a161705cc0aa982a14878f01832c4812deedd6b47019769d113e7045d8cdfa5354f934ea46e6120baacd4 SHA512 8b4aca37627ab11f394815ee7eaec785f78c8edec8c2c73f520c214d3e1b0e3990f915302b6296eda899323bf23af4ac7b2fbe586680797aed65afa23ba5defd
+MISC metadata.xml 550 BLAKE2B d48667a74c94f5234a1b3ddff6521574aaa8b7cc441b1e206b35c67a7ef331a946de527d4f8edd20d45bda50a7f3067508ac8a60f052f44073d773f14584c01b SHA512 e2f86c14d0dd02fc51f10f078546c800201b43a8d3904dc763f5a35773e0ded146618885ccb9754d1404bea959098b6e4ea02a37fb96d9ebe7f705e26f36df37
diff --git a/dev-python/pythonfinder/files/2.0.5-fix-import-cached-property.patch b/dev-python/pythonfinder/files/2.0.5-fix-import-cached-property.patch
new file mode 100644
index 000000000000..ce1af3244fbd
--- /dev/null
+++ b/dev-python/pythonfinder/files/2.0.5-fix-import-cached-property.patch
@@ -0,0 +1,13 @@
+diff --git a/src/pythonfinder/models/path.py b/src/pythonfinder/models/path.py
+index a8fb807..a933a91 100644
+--- a/src/pythonfinder/models/path.py
++++ b/src/pythonfinder/models/path.py
+@@ -19,7 +19,7 @@ from typing import (
+ Union,
+ )
+
+-from cached_property import cached_property
++from functools import cached_property
+ from pydantic import Field, root_validator
+
+ from ..environment import (
diff --git a/dev-python/pythonfinder/metadata.xml b/dev-python/pythonfinder/metadata.xml
new file mode 100644
index 000000000000..a9367d2f4b85
--- /dev/null
+++ b/dev-python/pythonfinder/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>oz.tiram@gmail.com</email>
+ <name>Oz Tiram</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">sarugaku/pythonfinder</remote-id>
+ <remote-id type="pypi">pythonfinder</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pythonfinder/pythonfinder-2.0.5.ebuild b/dev-python/pythonfinder/pythonfinder-2.0.5.ebuild
new file mode 100644
index 000000000000..9c74fb3a81be
--- /dev/null
+++ b/dev-python/pythonfinder/pythonfinder-2.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PythonFinder: Cross Platform Search Tool for Finding Pythons"
+HOMEPAGE="
+ https://github.com/sarugaku/pythonfinder
+ https://pypi.org/project/pythonfinder/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}/2.0.5-fix-import-cached-property.patch"
+)
+
+RDEPEND="
+ <dev-python/pydantic-2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest