summaryrefslogtreecommitdiff
path: root/dev-python/python-memcached
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-memcached
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-memcached')
-rw-r--r--dev-python/python-memcached/Manifest5
-rw-r--r--dev-python/python-memcached/metadata.xml19
-rw-r--r--dev-python/python-memcached/python-memcached-1.53-r1.ebuild43
-rw-r--r--dev-python/python-memcached/python-memcached-1.58.ebuild48
4 files changed, 115 insertions, 0 deletions
diff --git a/dev-python/python-memcached/Manifest b/dev-python/python-memcached/Manifest
new file mode 100644
index 000000000000..5c779f01ba7b
--- /dev/null
+++ b/dev-python/python-memcached/Manifest
@@ -0,0 +1,5 @@
+DIST python-memcached-1.53.tar.gz 35025 BLAKE2B 40d30ba35b8dc5d33c27a8a02d66ef7714c2851a3bb109b0cd4456f14408579e51baef8a6020ee75a21bfba468f6524c5163f4161676fc86788186832ff2ec4d SHA512 33ffd2778025a8e15beddf1660c4b5c9f1ba144adab5c36fd679e15508015c00e3e1185b5cc179cfcfc556b7c3ab44ed9914089e5ce9db66a04d0a658dd38bb3
+DIST python-memcached-1.58.tar.gz 30562 BLAKE2B 928aeca2b0d6d99fb16ee8c8c970ccc41aabb4c6385d962cb4208878f4f0eb1b1114c103118fc4ce6020e01d2260b9ffa83e96b2aba719cad6820e39d9fcfe3c SHA512 48f933f095751b476c122473fa1d9767cfe5c6c339a9ba71825a50cec23cbfc7b6493716458bfb1f2451c634c517519152105a2000be66bd0d389f94ea312138
+EBUILD python-memcached-1.53-r1.ebuild 1213 BLAKE2B 76827f4837a5d0bd58e84262a58dfebc297de4272f37d5d322df3ca36018d9f273c73fccf4a2ab94a5d0b3597b5526ddd6d83818af29fe55b4695222e07a3218 SHA512 e104823d6aad4fc854203d8efa60934efd5eb944d8a172503e6cd9931a9fe9200388a6439eb2f55bd8a4f20057200b6b047341ebec1f59190b23ae3b8c580554
+EBUILD python-memcached-1.58.ebuild 1287 BLAKE2B 0c19edcc732734e4d09ed52ed384c13cd8206708d29925c81091b1140739778b4d8f18ffa3ba7df3c20dd8678163ef5d7867c73ae7d3410fd460931a36101dbf SHA512 d81f3bcd2387bbb4d59138a1fe546c755cda8df8f7c9994cced47d9009de028408e87ff0a81a3b2c956aadac9b04e3cfc0924765069b80b0c354fca12345524a
+MISC metadata.xml 611 BLAKE2B fa7a75bea6b08f6ab65ff4b5d4d8e3022912ba8cb86c6dd3fd2d8f5bb224f89ae9db977c2197a39e6541193ed41366c4bdaa404138a18b2d31afc412b967cacc SHA512 9070f42bf5f3fb721f41309c7a24f29168f1179f9327f1334dcd5bd7b38ae98bbc682c2f0cfb7874c8e20e92ce25bffdc5d3f21870316c6d35cd57e1049f8d90
diff --git a/dev-python/python-memcached/metadata.xml b/dev-python/python-memcached/metadata.xml
new file mode 100644
index 000000000000..5a0000d36d7e
--- /dev/null
+++ b/dev-python/python-memcached/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+This is a Python based API (implemented in 100% python) for communicating with
+the memcached distributed memory object cache daemon.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">python-memcached</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-memcached/python-memcached-1.53-r1.ebuild b/dev-python/python-memcached/python-memcached-1.53-r1.ebuild
new file mode 100644
index 000000000000..2a091a9ae4c7
--- /dev/null
+++ b/dev-python/python-memcached/python-memcached-1.53-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python memcached client"
+HOMEPAGE="https://www.tummy.com/Community/software/python-memcached/
+ https://pypi.org/project/python-memcached/"
+SRC_URI="ftp://ftp.tummy.com/pub/python-memcached/old-releases/${P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( net-misc/memcached )"
+RDEPEND=""
+
+# Tests try to connect to memcached via TCP/IP. Please do not re-enable
+# until you get them all to pass properly while using the UNIX socket
+# only and not even trying to connect to memcached over TCP/IP.
+RESTRICT=test
+
+python_test() {
+ # Note: partial. Needs fixing. Stuff like that.
+
+ cd "${TMPDIR}" || die
+
+ local memcached_opts=( -d -P memcached.pid -s memcached.socket )
+ [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
+
+ memcached "${memached_opts[@]}" || die
+
+ "${PYTHON}" memcache.py --do-unix || die "Tests fail with ${EPYTHON}"
+
+ kill "$(<memcached.pid)" || die
+ rm memcached.pid || die
+}
diff --git a/dev-python/python-memcached/python-memcached-1.58.ebuild b/dev-python/python-memcached/python-memcached-1.58.ebuild
new file mode 100644
index 000000000000..84e590112e70
--- /dev/null
+++ b/dev-python/python-memcached/python-memcached-1.58.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python memcached client"
+HOMEPAGE="
+ https://www.tummy.com/Community/software/python-memcached/
+ https://pypi.org/project/python-memcached/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ net-misc/memcached
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+# Tests try to connect to memcached via TCP/IP. Please do not re-enable
+# until you get them all to pass properly while using the UNIX socket
+# only and not even trying to connect to memcached over TCP/IP.
+RESTRICT=test
+
+python_test() {
+ # Note: partial. Needs fixing. Stuff like that.
+
+ cd "${TMPDIR}" || die
+
+ local memcached_opts=( -d -P memcached.pid -s memcached.socket )
+ [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
+
+ memcached "${memached_opts[@]}" || die
+
+ "${PYTHON}" memcache.py --do-unix || die "Tests fail with ${EPYTHON}"
+
+ kill "$(<memcached.pid)" || die
+ rm memcached.pid || die
+}