summaryrefslogtreecommitdiff
path: root/dev-python/python-memcached/python-memcached-1.58.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-memcached/python-memcached-1.58.ebuild')
-rw-r--r--dev-python/python-memcached/python-memcached-1.58.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-memcached/python-memcached-1.58.ebuild b/dev-python/python-memcached/python-memcached-1.58.ebuild
new file mode 100644
index 000000000000..84e590112e70
--- /dev/null
+++ b/dev-python/python-memcached/python-memcached-1.58.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python memcached client"
+HOMEPAGE="
+ https://www.tummy.com/Community/software/python-memcached/
+ https://pypi.org/project/python-memcached/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ net-misc/memcached
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+# Tests try to connect to memcached via TCP/IP. Please do not re-enable
+# until you get them all to pass properly while using the UNIX socket
+# only and not even trying to connect to memcached over TCP/IP.
+RESTRICT=test
+
+python_test() {
+ # Note: partial. Needs fixing. Stuff like that.
+
+ cd "${TMPDIR}" || die
+
+ local memcached_opts=( -d -P memcached.pid -s memcached.socket )
+ [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
+
+ memcached "${memached_opts[@]}" || die
+
+ "${PYTHON}" memcache.py --do-unix || die "Tests fail with ${EPYTHON}"
+
+ kill "$(<memcached.pid)" || die
+ rm memcached.pid || die
+}