summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-26 13:56:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-26 13:56:06 +0000
commit7267fb40fb51ddbc9cc5c1c82b0a12807ef7b281 (patch)
treeee50984098515c85257df0802f24d6b82f9a0b92 /dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild
parent220317eb99d11e6c68af921f2855409bc506461a (diff)
gentoo auto-resync : 26:01:2023 - 13:56:06
Diffstat (limited to 'dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild')
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild b/dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..72414f29252b
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-black/
+ https://pypi.org/project/python-lsp-black/
+"
+SRC_URI="
+ https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ >=dev-python/python-lsp-server-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/black-22.3.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tomli.patch
+)