summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-black
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-26 13:56:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-26 13:56:06 +0000
commit7267fb40fb51ddbc9cc5c1c82b0a12807ef7b281 (patch)
treeee50984098515c85257df0802f24d6b82f9a0b92 /dev-python/python-lsp-black
parent220317eb99d11e6c68af921f2855409bc506461a (diff)
gentoo auto-resync : 26:01:2023 - 13:56:06
Diffstat (limited to 'dev-python/python-lsp-black')
-rw-r--r--dev-python/python-lsp-black/Manifest3
-rw-r--r--dev-python/python-lsp-black/files/python-lsp-black-1.2.1-tomli.patch94
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild (renamed from dev-python/python-lsp-black/python-lsp-black-1.2.1.ebuild)8
3 files changed, 103 insertions, 2 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index c3ada4d05c6e..02bbfa26dc21 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1,3 +1,4 @@
+AUX python-lsp-black-1.2.1-tomli.patch 2955 BLAKE2B 9627be0dcae6a723242e22831384caa772082842a1ae4758534ad40e99402a2f9adc8677b547a2ba899e5763e0d9785c51afced6aafc620d0e0927f6bf719997 SHA512 3fcea10adfd6f25abcf5dda95c4d2ed4e86666d06522baa014fe805dbc6c06a825af1491a931610eabdd5e907f4d34b94513aa3caa4ba43cc584859ae5a76035
DIST python-lsp-black-1.2.1.gh.tar.gz 9355 BLAKE2B f9c70ff07d9dfa31e3af919143deb8a49f43269469e8c64525f514624f4db67636da8254dae5274685ba2d883c8ddfd6dd9cb99981a337d7837d4007f15af11c SHA512 289b8f3642ed806409671d25e32997fb473720d0abd642c58c07d8c894831fa00f56dbc39e7d0fc8d98cad7de9f95ebdb6a0f637b8b4bbcc2a0716690feb647e
-EBUILD python-lsp-black-1.2.1.ebuild 703 BLAKE2B 89c7399c1b3139efbf77f7a6b0f1efb28d2aa142a01e6d2ac4d54c8bf4085883728b62f5bad5d559b723392b948786b4884085de434fb007b9923525c1370ff3 SHA512 bfd0ffc69d22cf555d411c61e437e069e469ca584649842632f9efa2d1f8e815d3e7d37d4cf9abe8a73d709e829503ded371257564a12a503e85df293e6dc7d0
+EBUILD python-lsp-black-1.2.1-r1.ebuild 791 BLAKE2B 376cc8a9bb0ecf16dc28b6f0402d0ef2982fa49d8010625d4172b349a85e87cbb7930ff6b25b5c327e22c9e396e80494fb9922d1161cb6f0149968cc989d9044 SHA512 f9b3aaa2cfcd4deb47b90d0033498edd280e533314f0e26173976b220a0d8708bf49a50349b5040f6410f806b70ff4f76bd309412b32b428e449bee7c47311a2
MISC metadata.xml 530 BLAKE2B 385bef4e8337f4a4fbcdbd32f52dec0b0758dd0eba50c9492465caee46dbbc96402b744d5835043f50f6c89147576c96305d8fcc4cedd42254ca2a19caf9234b SHA512 121b726a498e17b6244ecad14edd8fa3fcf23297516280f10b6b4fd5c1cb784f3a6caf902764977f8abd3cd3967db6d8fbac594c773969711dd572a487cae717
diff --git a/dev-python/python-lsp-black/files/python-lsp-black-1.2.1-tomli.patch b/dev-python/python-lsp-black/files/python-lsp-black-1.2.1-tomli.patch
new file mode 100644
index 000000000000..8ecef0287f40
--- /dev/null
+++ b/dev-python/python-lsp-black/files/python-lsp-black-1.2.1-tomli.patch
@@ -0,0 +1,94 @@
+From 80d34ca4f35baa654e5f1fee7860214950f1ae37 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 26 Jan 2023 12:07:11 +0100
+Subject: [PATCH] Replace the obsolete toml package with tomllib/tomli
+
+Use the modern `tomllib` module (in Python 3.11+) or its drop-in
+replacement `tomli` (for older Python versions) instead of the obsolete
+`toml` module. The latter is unmaintained and does not support TOML
+1.0.
+---
+ .pre-commit-config.yaml | 2 +-
+ pylsp_black/plugin.py | 12 +++++++++---
+ setup.cfg | 7 +++++--
+ 3 files changed, 15 insertions(+), 6 deletions(-)
+
+diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
+index 304770e..d5bd147 100644
+--- a/.pre-commit-config.yaml
++++ b/.pre-commit-config.yaml
+@@ -17,7 +17,7 @@ repos:
+ rev: v0.942
+ hooks:
+ - id: mypy
+- additional_dependencies: [black, types-pkg_resources, types-setuptools, types-toml]
++ additional_dependencies: [black, types-pkg_resources, types-setuptools]
+ - repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v4.1.0
+ hooks:
+diff --git a/pylsp_black/plugin.py b/pylsp_black/plugin.py
+index f013171..090b1b0 100644
+--- a/pylsp_black/plugin.py
++++ b/pylsp_black/plugin.py
+@@ -1,15 +1,20 @@
+ import logging
+ import os
++import sys
+ from functools import lru_cache
+ from pathlib import Path
+ from typing import Dict, Optional
+
+ import black
+-import toml
+ from pylsp import hookimpl
+ from pylsp._utils import get_eol_chars
+ from pylsp.config.config import Config
+
++if sys.version_info >= (3, 11):
++ import tomllib
++else:
++ import tomli as tomllib
++
+ logger = logging.getLogger(__name__)
+
+
+@@ -154,8 +159,9 @@ def _load_config(filename: str, client_config: Config) -> Dict:
+ return defaults
+
+ try:
+- pyproject_toml = toml.load(str(pyproject_filename))
+- except (toml.TomlDecodeError, OSError):
++ with open(pyproject_filename, "rb") as f:
++ pyproject_toml = tomllib.load(f)
++ except (tomllib.TOMLDecodeError, OSError):
+ logger.warning(
+ "Error decoding pyproject.toml, using defaults: %r",
+ defaults,
+diff --git a/setup.cfg b/setup.cfg
+index 47510d5..257add6 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -18,7 +18,10 @@ classifiers =
+
+ [options]
+ packages = find:
+-install_requires = python-lsp-server>=1.4.0; black>=22.3.0; toml
++install_requires =
++ python-lsp-server>=1.4.0
++ black>=22.3.0
++ tomli; python_version<'3.11'
+ python_requires = >= 3.7
+
+ [options.entry_points]
+@@ -26,7 +29,7 @@ pylsp = pylsp_black = pylsp_black.plugin
+
+ [options.extras_require]
+ # add any types-* packages to .pre-commit-config.yaml mypy additional_dependencies
+-dev = isort>=5.0; flake8; pre-commit; pytest; mypy; pytest; types-pkg_resources; types-setuptools; types-toml
++dev = isort>=5.0; flake8; pre-commit; pytest; mypy; pytest; types-pkg_resources; types-setuptools
+
+ [flake8]
+ max-line-length = 88
+--
+2.39.1
+
diff --git a/dev-python/python-lsp-black/python-lsp-black-1.2.1.ebuild b/dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild
index b14d4254f151..72414f29252b 100644
--- a/dev-python/python-lsp-black/python-lsp-black-1.2.1.ebuild
+++ b/dev-python/python-lsp-black/python-lsp-black-1.2.1-r1.ebuild
@@ -29,8 +29,14 @@ RDEPEND="
BDEPEND="
test? (
- dev-python/toml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
)
"
distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tomli.patch
+)