summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xvfb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 22:29:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 22:29:52 +0000
commit4dc9bfa1f12673bbf1343e64af7e0cd715534a9f (patch)
treeb6bfc88046aa092bbc03342aef7eccf310d43692 /dev-python/pytest-xvfb
parent8cd3c41aa0ccead302235680b9e2fa9903d7548e (diff)
gentoo auto-resync : 25:11:2023 - 22:29:52
Diffstat (limited to 'dev-python/pytest-xvfb')
-rw-r--r--dev-python/pytest-xvfb/Manifest2
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild15
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/pytest-xvfb/Manifest b/dev-python/pytest-xvfb/Manifest
index f4f5c51ac443..d458880914a0 100644
--- a/dev-python/pytest-xvfb/Manifest
+++ b/dev-python/pytest-xvfb/Manifest
@@ -1,3 +1,3 @@
DIST pytest-xvfb-3.0.0.tar.gz 8607 BLAKE2B a1256b121a66c0b778a45f695754363ec241699197000f6237473dc2d54c0eeff499722073b00280ca242d695c192ff4fd985931a42bbb52a0f8e2424867b60a SHA512 9aec1681656badf81fbac3a0d621b163810001e155a1cb8fd35e0f8c8d3ee52556e622adc0468d8e7455b15ba0f5103622fae1aa2493a7053ca78f092e582cf1
-EBUILD pytest-xvfb-3.0.0.ebuild 624 BLAKE2B ef93990550b2cb7b752153de322935487ed5b9094c436afa75dce547c6dda914ee95f04bda475a46133a631f943395ea68cacadc52b21dcf48a9548ed5d4bc9e SHA512 404620e5e5f815db0da52e58198db8e75827f1c4ac497e4609b9ed6b383c63e4a5d78d418860e7703cfb8cca91498b22645f453d182afa70935439da08e97381
+EBUILD pytest-xvfb-3.0.0.ebuild 746 BLAKE2B ca22d1831031c97976628e7b94ccac08a5fc04e70258bd2f063dfefc192686aecc1eee18c24db5f98963377ed16be6f26b928d259f31b4ac741eaf8cd34519fd SHA512 0b241b6cda6d18264fe4260b307b2c04d7dca24f76d3a2457e2b8d3b55c2596ec56a575c15d808bdfc6e528b536eab36a3bbd156436834c4432ec92a6ba61fba
MISC metadata.xml 408 BLAKE2B 514661a3043e602906bf900b7da93f0671fceb02ba2d54b5e781b6a68f583a03915e62944520a4900af78b0bc3a031036f18d766ab9c9833e92c031282be438f SHA512 849d377dbbeedff1a8d6afd613b2aeb21c5bb3d7825c141b3c53a395bc054cc1ac46e71e9404e2c3e2e22202d23da73bc40a74785c7c90189dbc9f5d04916577
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
index 88cb81666803..4f09bfae28da 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
@@ -7,22 +7,29 @@ DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="tk"
+
inherit distutils-r1 pypi
DESCRIPTION="Pytest plugin to run Xvfb for tests"
-HOMEPAGE="https://pypi.org/project/pytest-xvfb/"
+HOMEPAGE="
+ https://github.com/The-Compiler/pytest-xvfb/
+ https://pypi.org/project/pytest-xvfb/
+"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
- x11-base/xorg-server[xvfb]"
+ x11-base/xorg-server[xvfb]
+"
distutils_enable_tests pytest
python_test() {
- epytest -p xvfb --runpytest=subprocess
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_xvfb
+ epytest --runpytest=subprocess
}