summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild')
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
index 88cb81666803..4f09bfae28da 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
@@ -7,22 +7,29 @@ DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="tk"
+
inherit distutils-r1 pypi
DESCRIPTION="Pytest plugin to run Xvfb for tests"
-HOMEPAGE="https://pypi.org/project/pytest-xvfb/"
+HOMEPAGE="
+ https://github.com/The-Compiler/pytest-xvfb/
+ https://pypi.org/project/pytest-xvfb/
+"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
- x11-base/xorg-server[xvfb]"
+ x11-base/xorg-server[xvfb]
+"
distutils_enable_tests pytest
python_test() {
- epytest -p xvfb --runpytest=subprocess
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_xvfb
+ epytest --runpytest=subprocess
}