summaryrefslogtreecommitdiff
path: root/dev-python/pytest-system-statistics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 21:21:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 21:21:18 +0000
commitb118032096b3380de251b5de2466f5198fd2930a (patch)
tree992376912dd2522e0078f8350735c14bd0b77149 /dev-python/pytest-system-statistics
parent177349fb1459039cc30cb8e3936af4117d038c16 (diff)
gentoo auto-resync : 10:12:2022 - 21:21:18
Diffstat (limited to 'dev-python/pytest-system-statistics')
-rw-r--r--dev-python/pytest-system-statistics/Manifest2
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild49
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/pytest-system-statistics/Manifest b/dev-python/pytest-system-statistics/Manifest
index 75f4bf6c606c..b784c5b75b0a 100644
--- a/dev-python/pytest-system-statistics/Manifest
+++ b/dev-python/pytest-system-statistics/Manifest
@@ -1,5 +1,3 @@
DIST pytest-system-statistics-1.0.2.gh.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
-DIST pytest-system-statistics-1.0.2.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
EBUILD pytest-system-statistics-1.0.2-r1.ebuild 1290 BLAKE2B 1f174d7c693dbc16ed690117899d365765c8be84b4a1c8bd0c84805202f73260ecb3745230950ad5ca1ceb75f227f0a3695d17e4c75a70612185e068f7d54706 SHA512 c8b5202743136d938d36a24b1d6c3da189d5e8cc453823916dc2db1bf1d550b7868f1e40446f72d098aaec05e09a2fcd73cac083dc1d4b9cce25f3b9d210a91b
-EBUILD pytest-system-statistics-1.0.2.ebuild 1287 BLAKE2B e022b0b1c59f0ad4c66194941c095fa790bb273cca566ca2beb9ac44365d81d789aba7246ab8bb2552867cdf6cc5e0fe17a71b3fc02cdbc16a77bb769fa017c4 SHA512 4d5ee20cb93e02e772bf4dc2b41ae98de0794013850cf69a3c947a699c0017c44e805f9dc83c607c0f8e51c490cadcf5d241386fb9a980a7b1610d7dc8b2349b
MISC metadata.xml 337 BLAKE2B 00bcf31ed6a7b0b94fe3bc0f3031d64bdd682be4797a4f2878ac0d66012d8c026a7295c923f9081f9e7b1b2dc1fd7c6dc7a4e33dfcd97f80785a737815979313 SHA512 a28c702734f0907afdb667a42e8d2672ab938bb4802f4e55e69de872694176b5424cd7073a9b2caee7dbe856fa511e41447ed30e49cc64d053a14b9ad830766a
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
deleted file mode 100644
index cfad9b945e60..000000000000
--- a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
-HOMEPAGE="
- https://pypi.org/project/pytest-system-statistics/
- https://github.com/saltstack/pytest-system-statistics
-"
-SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-subtests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
- sed -e "/setuptools_scm/ d" -i setup.cfg || die
- sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
-
- printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest -k 'not proc_sys_stats'
-}