summaryrefslogtreecommitdiff
path: root/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild')
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
deleted file mode 100644
index cfad9b945e60..000000000000
--- a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
-HOMEPAGE="
- https://pypi.org/project/pytest-system-statistics/
- https://github.com/saltstack/pytest-system-statistics
-"
-SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-subtests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
- sed -e "/setuptools_scm/ d" -i setup.cfg || die
- sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
-
- printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest -k 'not proc_sys_stats'
-}