summaryrefslogtreecommitdiff
path: root/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 03:10:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 03:10:55 +0000
commit670a2ef95331c60f32a0831bfe79445340356b0b (patch)
treecca4590ecf2c13488c7ef6c478f3e49acec2922d /dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild
parentd05150f06fa67b115a83f822b1e285dca011e1b7 (diff)
gentoo auto-resync : 03:11:2022 - 03:10:55
Diffstat (limited to 'dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild')
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..28c76f28eac4
--- /dev/null
+++ b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
+HOMEPAGE="
+ https://pypi.org/project/pytest-system-statistics/
+ https://github.com/saltstack/pytest-system-statistics
+"
+SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e "/setuptools_scm/ d" -i setup.cfg || die
+ sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
+
+ printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest -k 'not proc_sys_stats'
+}