summaryrefslogtreecommitdiff
path: root/dev-python/pytest-system-statistics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 03:10:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 03:10:55 +0000
commit670a2ef95331c60f32a0831bfe79445340356b0b (patch)
treecca4590ecf2c13488c7ef6c478f3e49acec2922d /dev-python/pytest-system-statistics
parentd05150f06fa67b115a83f822b1e285dca011e1b7 (diff)
gentoo auto-resync : 03:11:2022 - 03:10:55
Diffstat (limited to 'dev-python/pytest-system-statistics')
-rw-r--r--dev-python/pytest-system-statistics/Manifest2
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pytest-system-statistics/Manifest b/dev-python/pytest-system-statistics/Manifest
index bb6c3a8968a0..adb3e402a0c4 100644
--- a/dev-python/pytest-system-statistics/Manifest
+++ b/dev-python/pytest-system-statistics/Manifest
@@ -1,3 +1,5 @@
+DIST pytest-system-statistics-1.0.2.gh.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
DIST pytest-system-statistics-1.0.2.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
+EBUILD pytest-system-statistics-1.0.2-r1.ebuild 1292 BLAKE2B b61c167b3ff3b4227c03a2382db73d8fa177213ca371df3a6d9a8a5e572c69b25aaec1d28d39ff138996def7e77260fb0ee7fb703142ceb0ce1c1265b1ed0b14 SHA512 e9cce27bf919627881331f996aa17fed7593c9b313b6c2be16d348a77fa95026c8d126a7dd14d1a0e704089b402ba9e08f63c5d73bc2b1e5b38073cc3d061994
EBUILD pytest-system-statistics-1.0.2.ebuild 1287 BLAKE2B e022b0b1c59f0ad4c66194941c095fa790bb273cca566ca2beb9ac44365d81d789aba7246ab8bb2552867cdf6cc5e0fe17a71b3fc02cdbc16a77bb769fa017c4 SHA512 4d5ee20cb93e02e772bf4dc2b41ae98de0794013850cf69a3c947a699c0017c44e805f9dc83c607c0f8e51c490cadcf5d241386fb9a980a7b1610d7dc8b2349b
MISC metadata.xml 337 BLAKE2B 00bcf31ed6a7b0b94fe3bc0f3031d64bdd682be4797a4f2878ac0d66012d8c026a7295c923f9081f9e7b1b2dc1fd7c6dc7a4e33dfcd97f80785a737815979313 SHA512 a28c702734f0907afdb667a42e8d2672ab938bb4802f4e55e69de872694176b5424cd7073a9b2caee7dbe856fa511e41447ed30e49cc64d053a14b9ad830766a
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..28c76f28eac4
--- /dev/null
+++ b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
+HOMEPAGE="
+ https://pypi.org/project/pytest-system-statistics/
+ https://github.com/saltstack/pytest-system-statistics
+"
+SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e "/setuptools_scm/ d" -i setup.cfg || die
+ sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
+
+ printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest -k 'not proc_sys_stats'
+}