summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
commit128025db16ea525715d1f5170c635c4f42ce4881 (patch)
tree07a1048840d97aefa9778386f8a8abc27940c708 /dev-python/pytest-httpx
parent37cf2a8dbadd546a550aac7c8079c3f77427cb63 (diff)
gentoo auto-resync : 13:04:2023 - 11:43:14
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index f304ff04b94c..d15cd5384149 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest-httpx-0.21.3.gh.tar.gz 24373 BLAKE2B 8efa85974128a0c9d78bbc23b7c9bca17e68ebb09dafd3b49e5a09df54bd2808ab6e7995ab407b78495ac12a80239d7397169c8de539ec559a8c7cf95239b495 SHA512 8c25a702b9c049354a0f0b232eefeae5ac0c47764af023c89aba6829309971a1d79a0dab3e4d6275a6bf0f32f3a8309c9559eb22c9b742a6576ecea37ff0d15d
+DIST pytest-httpx-0.22.0.gh.tar.gz 24409 BLAKE2B 9db6622e4997ddf0a70c1a0ef835b077640b3ce1d1c19792feda573577fac1ecfba16bcb7ecb8e4c1578b345764d8301aa121335a259dc91a4805173a549bea3 SHA512 fd89ce70113608195eb8fa8e3d7465d9d15b5a300e7c00f3c50417ba9b205081671fbda9591bdb16accb1973da00f5d0bede9e73a3351b0652080d4059c5f6d6
EBUILD pytest-httpx-0.21.3.ebuild 774 BLAKE2B 7eff7358b4d922d9e06886de8776f87085171522b9c397454cbf7ea82ea35ed46a24160509c107ebff92ef281dae6091d62b14809b530c0891075487b8f65634 SHA512 fd260a4ca72148a90b78cd8ad5c7fd935aa742bb2daf1d742bdb313c2aa48c5cea35eba7278095cf4ce77fd2fb68526d0b9e2bc093110ac94d5c08930b38de4d
+EBUILD pytest-httpx-0.22.0.ebuild 859 BLAKE2B c908d26bf18ca0f711cb34c9daf9762c268714fec4a3a7aeae9aca7ac732ec0fd5172a419ea38393cbc6f8e14ff6fffba2e2cc9c19d24282f64fa23b43f41591 SHA512 85c01f1c1066da679abc2b17c1091ed06553c708b024b0c74d3eb57ae1ac4a45881118ba44e330a58f65cf5613a74e088efcb6dda0aac22a0448a7d5c0bc236d
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild
new file mode 100644
index 000000000000..aa42666a0557
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+# no tests in sdist as of 0.22.0
+# https://github.com/Colin-b/pytest_httpx/pull/95
+SRC_URI="
+ https://github.com/Colin-b/pytest_httpx/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.24*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest