summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild')
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild
new file mode 100644
index 000000000000..aa42666a0557
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+# no tests in sdist as of 0.22.0
+# https://github.com/Colin-b/pytest_httpx/pull/95
+SRC_URI="
+ https://github.com/Colin-b/pytest_httpx/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.24*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest