summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/pytest-django
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest6
-rw-r--r--dev-python/pytest-django/pytest-django-3.8.0.ebuild27
-rw-r--r--dev-python/pytest-django/pytest-django-3.9.0.ebuild (renamed from dev-python/pytest-django/pytest-django-3.4.4.ebuild)3
3 files changed, 33 insertions, 3 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index d4854e138368..5973d2ea265e 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,3 +1,5 @@
-DIST pytest-django-3.4.4.tar.gz 66962 BLAKE2B a989009eccab4bbd96e32ed1b6b5d03ca8105026c6d9219ea09f6b33fe2087a30d9042e2cd5a313196ed67cc1c5dc940d04fe981dda0da4f25cf16a43e88471a SHA512 a851b27e9abc4829a47abb5da40cbd69fea5c48b05c81f88910d4345696c6d01f78e07ac489cec7cfb5724dd8432891ff9260dc585e720d758491906812661df
-EBUILD pytest-django-3.4.4.ebuild 696 BLAKE2B a7f0b53c08c6dc0bbdb15b546a8df7f8e4cbbc0b97354ef8ec7b8baa3c093382494834090a8e4ee565cf6501ca50be2affd7689f85c31e4e2609a5c40933d02e SHA512 e0e7a2f617a06295262a390444c359f5afec8f7c152f14ce5a25f88a1af633ca3acafc541a6e0ebb249063d06f4fe222570f8cf998f43d7e2614f2aa928b73d5
+DIST pytest-django-3.8.0.tar.gz 70013 BLAKE2B 75e2ebf6a3a61cfabdc59ceb6f60a85ab4e257b22e3ff55bcda122a370317bf91a9f90640d9edc17da2cc3bdc6dcf6e84dd1e3438dff91b07f5682713804d513 SHA512 3ce45b08f913c3e20b679c7f7a07818ffab7088fd90757794e1807db2025d655c195304da3ca3905c8ddb58fc9708000dc492f4114df8f4e7bfdb1285ebd997a
+DIST pytest-django-3.9.0.tar.gz 70498 BLAKE2B 0f3cf7ffd528f00dd0c7dd6babcb64833ec3684c7b62dcb8757b0f90cdcdddabffdbff240774ed6fb2a294e27da2acd7f396298ff2884be6e5b4c8d9c632d008 SHA512 92985e66f47c91363d19fe2bfe8ccab14212be577692f90923dbbae4c8d406cf698796d485af2b721863392810fc07c6f11ada0c61589cd1861f0d34a732effe
+EBUILD pytest-django-3.8.0.ebuild 728 BLAKE2B 109187818552dfdfece971cd88832be89aa595d64617a9de1e97493d54351b32cb212533a9acfbf631b4dc8cda7cef023e97d09261f8b0066ebd735b8b539c71 SHA512 209e200a754b6afe8b19a315991d0d2eace619189e4e1cc9ddda0386570b3a0ebb1de447a0f3578fe66692b11273beac91cb4c2cf507d5de8d65541dfe6b87a9
+EBUILD pytest-django-3.9.0.ebuild 729 BLAKE2B 952250a3344800163d4a695e2d926341643a414fd9fa845571dfb4facdfbbc74124ce80a2d32e439d6c60609da0d627db22473accdeb5cfde11ddaa423e46029 SHA512 496fa81c41038cf9234271fd5e6124c1c431ab9ae6b7d1c8c05a86833bb827dccfea69375cddc79f942177a3c834745eea4ca54821d744084cfdc6179ca0fbae
MISC metadata.xml 380 BLAKE2B 6d349594a1198f6cbf2c6e0e80276f3d27454346cdbd24654506221647304fc3d3a0c9b8deadb920c4881b62c779951df2cda6a773f4f251c7c31d166fdf7b2c SHA512 65163d6f99c4d2be86bbedad07b756eda2aa639cd612e0ffaf95dc0707e72de8b406ad51d2a482925790c837bc7c3d4ccd5dc3fd070da6599e13278db03ab006
diff --git a/dev-python/pytest-django/pytest-django-3.8.0.ebuild b/dev-python/pytest-django/pytest-django-3.8.0.ebuild
new file mode 100644
index 000000000000..1c78196ecdf7
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-3.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="https://pypi.org/project/pytest-django/ https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"
diff --git a/dev-python/pytest-django/pytest-django-3.4.4.ebuild b/dev-python/pytest-django/pytest-django-3.9.0.ebuild
index 004f497cb80c..d8944a9de33a 100644
--- a/dev-python/pytest-django/pytest-django-3.4.4.ebuild
+++ b/dev-python/pytest-django/pytest-django-3.9.0.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit distutils-r1