summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django/pytest-django-3.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-django/pytest-django-3.8.0.ebuild')
-rw-r--r--dev-python/pytest-django/pytest-django-3.8.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-django/pytest-django-3.8.0.ebuild b/dev-python/pytest-django/pytest-django-3.8.0.ebuild
new file mode 100644
index 000000000000..1c78196ecdf7
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-3.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="https://pypi.org/project/pytest-django/ https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"