summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-cython/pytest-cython-0.1.0.ebuild')
-rw-r--r--dev-python/pytest-cython/pytest-cython-0.1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
new file mode 100644
index 000000000000..60ca2ab4411f
--- /dev/null
+++ b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for testing Cython extension modules"
+HOMEPAGE="https://github.com/lgpage/pytest-cython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"