summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-cython
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-cython')
-rw-r--r--dev-python/pytest-cython/Manifest3
-rw-r--r--dev-python/pytest-cython/metadata.xml12
-rw-r--r--dev-python/pytest-cython/pytest-cython-0.1.0.ebuild22
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-cython/Manifest b/dev-python/pytest-cython/Manifest
new file mode 100644
index 000000000000..31da301c9e2f
--- /dev/null
+++ b/dev-python/pytest-cython/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-cython-0.1.0.tar.gz 19109 BLAKE2B 75895992402f36010385e0851cce4532825d374cc9d5af1b45d4dc938070da1f9e8c9901601ac10e3fa9a76fd4f0affd3f0dac6d8857eea88c73cbc1686ce613 SHA512 65d8d25f95f2419ae76902cad8f0f4c9b810dbbba80621d301f53d2128dfeb11c4d74e2ac4f1e39f63aadfc1404e9000c0668efbab4793d307f0b90345023771
+EBUILD pytest-cython-0.1.0.ebuild 532 BLAKE2B b8bbce450b30fcd5cb9f0b58802266ccb8ac86a75f0768336d49b9d23bd1a58550b1319a550c7763a0779eb540bbb5772498f4f695539821e674e4363eff8814 SHA512 77f132fa58d9dd1d5b7140de45fa648061c38ccb5f61222132e6f88d6f1f9ded302c3711042027fe155e975e22e12a226b3480a22848c997e1e0f7fa8258aaed
+MISC metadata.xml 388 BLAKE2B d63e4b52d4d5ce203c3850984e6b09accf61f67d8c5de98782de50de276c8a6a6747850128fd5849f026a852a148a53a971ba371f5ab5a9d2ba9e549242352c5 SHA512 9a0cead855da37845b25a91c72b9211d9a273db49da4fc925c593f7f083f5d7aec6376dfd7db1dea88ee4ca0b51a3ad58e000af37960aa2afc8416ed78b3ff64
diff --git a/dev-python/pytest-cython/metadata.xml b/dev-python/pytest-cython/metadata.xml
new file mode 100644
index 000000000000..535d87310a6a
--- /dev/null
+++ b/dev-python/pytest-cython/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-cython</remote-id>
+ <remote-id type="github">lgpage/pytest-cython</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
new file mode 100644
index 000000000000..60ca2ab4411f
--- /dev/null
+++ b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for testing Cython extension modules"
+HOMEPAGE="https://github.com/lgpage/pytest-cython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"