summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-01 19:11:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-01 19:11:24 +0100
commit0a772e9952c6683769ac22be1b2304fcd86f02cb (patch)
tree913ccfa8988bae59ab9651b5b9a20e1265157f7d /dev-python/pytest-cov
parent8598ab9ad325d12d0f2901ecc0973e430dacd2b3 (diff)
gentoo auto-resync : 01:10:2022 - 19:11:24
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest2
-rw-r--r--dev-python/pytest-cov/pytest-cov-4.0.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 558f3cffc5a0..415f616e3569 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,4 +1,6 @@
AUX pytest-cov-3.0.0-coverage-6.2.patch 1034 BLAKE2B 433d761faae7c929b09e6d7a346fa1129acb427939756efa4d465ed6a6a20fb45ad09f890ce9d9b95c45862bc072a20d9038a1acca06de1963008119188b3e87 SHA512 85501e1c16f9716a3c2b04c79786e657e71ed58a6b0d338458e4cd17abff19eb85dd4b4c6d427e5f17d259d8ce970e79682c613a51b252cd506b1cd895fd8ee6
DIST pytest-cov-3.0.0.tar.gz 61440 BLAKE2B 85f0b079c4c373191553271e34e78af68ac69ea53e3721aa0d43eb9dd55be935570eb15c0f8b954e4c0de6201c004ddef435ea70b03cfda893ecdcc230c283e7 SHA512 289d1b1e29dcc3461276de4c1bbd3884e4ec957efb7dd4c330bc3f25f1b978cbee64c0e2882b419eee5f9ccf44c9d1a23ce47a1b7cc7e436b9ebe894e4c11ae8
+DIST pytest-cov-4.0.0.tar.gz 62013 BLAKE2B af8a12955e3f22cd9dc257874f86c04c3c6e29f4af2d2838f37ca196c4955dcf4007c7b404f31c303d0eef6c3735fa1a6268c3bb9f01ed54860750ca2f83b6f5 SHA512 fb993be4d86b29a44e4f2ccd2309d99ab9fe8e6b291abbc2a8a3fc8b36479491165a242a20bfa9886dfd296fcc827da9984b556fdbe9a3ac496ac5b6ba379012
EBUILD pytest-cov-3.0.0-r1.ebuild 1704 BLAKE2B 873030ba19d725b309861ee7ea02b8e54d680100aab0239c5efb66eee251d15c0a8dd0f2f948121173dc906aed99d2476df0250d3e9fd13e1a2dcc5f56ca1925 SHA512 bea2d3fbe99347972bcc22c566365b0322e97a30f31fe71ec4c78670d8875e9040bb69c85d41840da1f67e4e4e30cdc496e816624b1aa748eaf8f16708a4386d
+EBUILD pytest-cov-4.0.0.ebuild 1659 BLAKE2B d542d52ee2d6b1d171f6c30c63096a3ab0e356982b6bfce851ce3d6786a2594fcd06777931829c72244035fea1f4d8ca95d70718bf4c392f53caf259a09126cc SHA512 ed1da34ac0e2d83413e2257419d2c92b4099f90df9adba3e4bf946c9834c6a6488baa2d4e2f5cbca988ab4f8478dfa0ee16fd726d81012bbbb929dd45e30d30f
MISC metadata.xml 412 BLAKE2B 0d79131c6fd8adf72493a7c333959e065cf4f2231f6c770800b6d05ff9afcc246cd202406bea6e28f6b0fd23ee6197aa8dac2dd59d0a89d9b07741f57e8fa5e8 SHA512 d1aab9ea8042bf810398a4195fd3595a8abbeb060ab38fd7b7e40085c8d5f22ecb78bab02e2331d4588199d88e0d3848413d75a18fe4373ecd9940a3c990c604
diff --git a/dev-python/pytest-cov/pytest-cov-4.0.0.ebuild b/dev-python/pytest-cov/pytest-cov-4.0.0.ebuild
new file mode 100644
index 000000000000..00e9dce47cda
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-4.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for coverage reporting"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-cov/
+ https://pypi.org/project/pytest-cov/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme
+distutils_enable_tests pytest
+
+python_test() {
+ # NB: disabling all plugins speeds tests up a lot
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_cov.plugin,xdist.plugin,xdist.looponfail
+
+ local EPYTEST_DESELECT=(
+ # attempts to install packages via pip (network)
+ tests/test_pytest_cov.py::test_dist_missing_data
+ # TODO
+ tests/test_pytest_cov.py::test_contexts
+ )
+
+ # TODO: why do we need to do that?!
+ # https://github.com/pytest-dev/pytest-cov/issues/517
+ ln -s "${BROOT}$(python_get_sitedir)/coverage" \
+ "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
+
+ epytest
+
+ rm "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
+}