summaryrefslogtreecommitdiff
path: root/dev-python/pytest-bdd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/pytest-bdd
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest4
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild14
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-5.0.0.ebuild38
3 files changed, 51 insertions, 5 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 43a0b95bd7b3..f8b7da062d2c 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,3 +1,5 @@
DIST pytest-bdd-4.1.0.tar.gz 61079 BLAKE2B 3bf7863b7244e0fa02de48f3c8d113427c9a9d546d1a5d95dbc025bcdf0bd60931fac55d7328c96a3b29b8b15da833c85c089cee19ee4f8a2bc639dd1b3c4e59 SHA512 54ce5ae2f7b3deff7d436d42f80fc47892707eb1e6e76469dda9753ff0b2d727bb47b5be300eadccadd87838aee43130fec5dff6441353eb07c0787c84d55afa
-EBUILD pytest-bdd-4.1.0.ebuild 938 BLAKE2B 55656949f2b7cdb37c6c8ae4f9b5dc8bdb411aea11251c2a011bdd22f31e51ef3638260705073aa325372f819997792a96d7dd48713ec113ce784a27d95ace57 SHA512 b6df46499aca30fb61993568498d379df24de337f4f325d8a85c5dea12788b1ffff0c6a09a5feb99d93d8667e03693b71bda4eea6816b916a12eb700f77a2144
+DIST pytest-bdd-5.0.0.tar.gz 61174 BLAKE2B 6dd1d53614226d3515b0f61f71822363b559aa45789bab7f3416c75e603e87a1fe48627f36862f44bfa7ac6ec5023ad8afde6054ec67fc9a2e756be7de729fd1 SHA512 827e57d410b05207b6c646062ddb54b677e22441311820d3bd406df202b6e9344dedf59cd4868e89cfbf8606fe3f15559e4cc3958d100e4fa74f9b864e6faada
+EBUILD pytest-bdd-4.1.0.ebuild 1007 BLAKE2B f48521f15672f0591fb5ff819f3d4af0a1b2bbb52eabc6b37928127d6e58278c416eadfd028bc89a2a303b0199992fca1b30773424953d2e56bb33ce59becc8a SHA512 c8a57233df65d452173b22e6975225c0313c4af60d14b56036b92710b1fc1fa25999afc91b9538e490e9434b6ef5c7fb5114cbcd9b800e17f16059d3b19ee7fa
+EBUILD pytest-bdd-5.0.0.ebuild 1008 BLAKE2B 8dcbc27d1d810160140d346ec45f7c7733d5aa47d3fc51a5f8fb4ed2c679d47f9ccdbe1bd0d52f0876fc23ce5731e8a3356d4f1fa10b6e490fed3bfe23722ecc SHA512 6d50e4a4b1ffb20ff1c531df58bc29abee7449f3ebaa91248988fbfbb6436dc0db18afbc8d139e550d7834e9fe273b0545ec3cd174f8fe51dab01ae96229becc
MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
index f0ca5bb62830..1b1087b8edf8 100644
--- a/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
+++ b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
@@ -26,7 +26,13 @@ distutils_enable_tests --install pytest
DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-EPYTEST_DESELECT=(
- # result varies depending on current output terminal width
- tests/feature/test_gherkin_terminal_reporter.py::test_verbose_mode_should_preserve_displaying_regular_tests_as_usual
-)
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}
diff --git a/dev-python/pytest-bdd/pytest-bdd-5.0.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-5.0.0.ebuild
new file mode 100644
index 000000000000..e429be77bf70
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-5.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pypi.org/project/pytest-bdd/"
+SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/glob2[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse_type[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
+
+distutils_enable_tests --install pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}