summaryrefslogtreecommitdiff
path: root/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild')
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
index f0ca5bb62830..1b1087b8edf8 100644
--- a/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
+++ b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
@@ -26,7 +26,13 @@ distutils_enable_tests --install pytest
DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-EPYTEST_DESELECT=(
- # result varies depending on current output terminal width
- tests/feature/test_gherkin_terminal_reporter.py::test_verbose_mode_should_preserve_displaying_regular_tests_as_usual
-)
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}