summaryrefslogtreecommitdiff
path: root/dev-python/pysrt/pysrt-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-28 22:35:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-28 22:35:05 +0100
commit5c0cc325922d72d6e614def2a9b36ee95a46d2c1 (patch)
tree2734b6847fc660dd18cfcf5f839e14aad0188ad0 /dev-python/pysrt/pysrt-9999.ebuild
parent35a2663a10c1124ae2951397ed2a4435dc5808e5 (diff)
gentoo auto-resync : 28:10:2023 - 22:35:05
Diffstat (limited to 'dev-python/pysrt/pysrt-9999.ebuild')
-rw-r--r--dev-python/pysrt/pysrt-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/pysrt/pysrt-9999.ebuild b/dev-python/pysrt/pysrt-9999.ebuild
index 5943e93f9f56..122ca75948b9 100644
--- a/dev-python/pysrt/pysrt-9999.ebuild
+++ b/dev-python/pysrt/pysrt-9999.ebuild
@@ -4,11 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Python library used to edit or create SubRip files"
-HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+HOMEPAGE="
+ https://github.com/byroot/pysrt/
+ https://pypi.org/project/pysrt/
+"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
@@ -20,6 +24,8 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest