summaryrefslogtreecommitdiff
path: root/dev-python/pysrt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-28 22:35:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-28 22:35:05 +0100
commit5c0cc325922d72d6e614def2a9b36ee95a46d2c1 (patch)
tree2734b6847fc660dd18cfcf5f839e14aad0188ad0 /dev-python/pysrt
parent35a2663a10c1124ae2951397ed2a4435dc5808e5 (diff)
gentoo auto-resync : 28:10:2023 - 22:35:05
Diffstat (limited to 'dev-python/pysrt')
-rw-r--r--dev-python/pysrt/Manifest4
-rw-r--r--dev-python/pysrt/pysrt-1.1.2-r1.ebuild18
-rw-r--r--dev-python/pysrt/pysrt-9999.ebuild12
3 files changed, 26 insertions, 8 deletions
diff --git a/dev-python/pysrt/Manifest b/dev-python/pysrt/Manifest
index 137e341c9c88..bc33bd91855a 100644
--- a/dev-python/pysrt/Manifest
+++ b/dev-python/pysrt/Manifest
@@ -1,4 +1,4 @@
DIST pysrt-1.1.2.tar.gz 104371 BLAKE2B b6f8e1e6d0cc0ae7ac4a5eb1ac9c5444318fd579fd2cbd926bed932326c986743d3efc1b604353df92a3dc67ea0d47f9a77eeba28d561b3f69b4b63eff8b78ad SHA512 a3a0988068d3cc13e6d44aec548a94e79d9ed29cfcd1e8e35ff56b50f0feb32a1baac2220c5331281c98a19ad9a3e9f960832a661699921cde0d185ea21e9753
-EBUILD pysrt-1.1.2-r1.ebuild 607 BLAKE2B 3e6b740b5fbee1e8039ca5ebb1d9621794b723fb82ac1cd37d65f894d55feafa7f2263666c56c3e009c347ab490fe3b77f0092aea1f5c32ef9b4ab18e0402c9b SHA512 148bb92b3b939feba22d1778b7885df9b150d108fdd15d95465b8bd5e0a612c52bdf360146f94ff4d91683c146dca1d2d0ba99e1f934419df713a56366a059c3
-EBUILD pysrt-9999.ebuild 609 BLAKE2B 648de6f084cceda6667591308d5714fc82695955d370f097618cd605e0439a126dda4491512918fe9cb63121daa437949791bc867704183c44e90e09843432fe SHA512 666ad2c6b116396f017d14cdf85e9ec67215874f81ce7f9840cae2cb78ff610b5942149d76a2fc12d00f4fe07f91e28a8887d2c7a9b387f510b7f2acb9a465c4
+EBUILD pysrt-1.1.2-r1.ebuild 804 BLAKE2B 0518fa9f96768b38ab8342fae808b933aaada7bfdb070997b1d229145e3dc96ac2a3ec6683e0252832d7460ee4be5815473f3ec6759f1d9e742212d3c7e97929 SHA512 9a1deccc862a483a7e56027fb231e97217fb1dbe767626a4b5dbc960a7fcd93aebde5e03ea4f3ad92d640168280c56ef7eb034ffafdfd745fead0939944e4bbc
+EBUILD pysrt-9999.ebuild 619 BLAKE2B 9fb2abb0c25bf8246813be263c1c405b37a42607395c0dfebb1a4aa2b9334a0323d4a80abc7a94cae207548e82e6020665e7b36636812a7de6ed97bdd1279d0b SHA512 fb3def41d4dfb2b261777489353e9f501e9b01213df20a0b1fd1be2a9f7655c5d4dd1033f59ae2631645eddac8238c29946cf0c3bf99ff5a23d4ac03f2ff0b0a
MISC metadata.xml 450 BLAKE2B 885ee12aa4bb7a473150c80a7734e93af2a39ced0cdb27574d83d38f0b21972fcdf40fe59b9ff45bb374206736d80ca039e80d2a9d2959bcd7f89ace88db9adc SHA512 64268270437cc60598665bef2ae6eaf8a07e4f18efc78d28176ad7477e0dcaf48dcae5789ecb4b936e34ba090e06db8576eb75908de75c59a85c67f2269cf443
diff --git a/dev-python/pysrt/pysrt-1.1.2-r1.ebuild b/dev-python/pysrt/pysrt-1.1.2-r1.ebuild
index 9c4b2eee378c..3dcd3f63654d 100644
--- a/dev-python/pysrt/pysrt-1.1.2-r1.ebuild
+++ b/dev-python/pysrt/pysrt-1.1.2-r1.ebuild
@@ -4,11 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Python library used to edit or create SubRip files"
-HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+HOMEPAGE="
+ https://github.com/byroot/pysrt/
+ https://pypi.org/project/pysrt/
+"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
@@ -20,6 +24,14 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest
+
+src_prepare() {
+ # https://github.com/byroot/pysrt/commit/93f52f6d4f70f4e18dc71deeaae0ec1e9100a50f
+ sed -i -e 's:assertEquals:assertEqual:' tests/*.py || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/pysrt/pysrt-9999.ebuild b/dev-python/pysrt/pysrt-9999.ebuild
index 5943e93f9f56..122ca75948b9 100644
--- a/dev-python/pysrt/pysrt-9999.ebuild
+++ b/dev-python/pysrt/pysrt-9999.ebuild
@@ -4,11 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Python library used to edit or create SubRip files"
-HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+HOMEPAGE="
+ https://github.com/byroot/pysrt/
+ https://pypi.org/project/pysrt/
+"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/byroot/pysrt.git"
@@ -20,6 +24,8 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest