summaryrefslogtreecommitdiff
path: root/dev-python/pyscreenshot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/pyscreenshot
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/pyscreenshot')
-rw-r--r--dev-python/pyscreenshot/Manifest2
-rw-r--r--dev-python/pyscreenshot/pyscreenshot-2.3.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyscreenshot/Manifest b/dev-python/pyscreenshot/Manifest
index d2b4615bd624..05ddc411f515 100644
--- a/dev-python/pyscreenshot/Manifest
+++ b/dev-python/pyscreenshot/Manifest
@@ -1,3 +1,5 @@
DIST pyscreenshot-2.2.tar.gz 29726 BLAKE2B d1e314be360d4716b35b4302de82010dfc9a97212b3f4472b42e40f9470fd0575fe8f0ceb976adfe13059c0566413414e03f78189d4afa193d88a0aaf4c5c26e SHA512 6689ccbcd5c6164aeb12d911ee93c8958f6c6b5aaba5ba7d4073ee855e6398180ed27fce6299480b18b3d7ffad12cd17694c3db1f1c7373d4b25be0073d49338
+DIST pyscreenshot-2.3.tar.gz 34543 BLAKE2B a9ae6fc51ac62efabca7e9b4e08ee8ee05d778a3f8ea0bfaec5f0958bea7f6dd266e18a938350aac6fa1058fdb378cfa69cf6c5490768c39d7312be51e3d2630 SHA512 6919e4529a932b9a6e3dd28d60c628447b0e6f25df567db742b5bf14455373ad7340237bb4b77696c436be6f31211030b206d7152f4b61d16d6745f439f84425
EBUILD pyscreenshot-2.2.ebuild 1618 BLAKE2B af871f3177aec6da987058dcee2e8cc9447d0d40c881b8035fbafaf210450047240d4e71648a6b83846f7034b8559ec2f2dad939d65c5fdcec771c6b64d07d09 SHA512 d1faac137a5b51b73a79290822900e3d941a362bfc376976aed8239d0c4130e5da53be1421732bdc9f2972053938dae5d239da8598a3889d9d7576cdaa2f4308
+EBUILD pyscreenshot-2.3.ebuild 1013 BLAKE2B f50256cbfc64fcafdf7677b8400d70e9d8604d5e543a66b9db6eb3728eedea4d33bd3265bba4bf6bb32836e503d96e99d586a2f32fcfa94158e50cbbd2bcc01c SHA512 c0dc3e699c1498b14c323e74d04f52a9ebf8ddcc3235a25dfb8ddcb4c4496e8192dcc90b64724f2829a029f4aee6cd7adceedc8f31439ce00a31cdf1e5a67006
MISC metadata.xml 450 BLAKE2B bd7e7fa6219b153954486f9457cc9ed56a055ee8caa2d04f0f6d587b7df88a8abe4b51165c1220ae1fbb7a3a2314f10851a6bdc35336305829e31a82d7004d4e SHA512 dd24b4495cf676ea8c90ad639d2177b27c725e21bbed0d6a64f0a4ecc5226c4a332c018306d3dd231409063cd179215c1e80c6efca1001ca9a36f58472fa82a3
diff --git a/dev-python/pyscreenshot/pyscreenshot-2.3.ebuild b/dev-python/pyscreenshot/pyscreenshot-2.3.ebuild
new file mode 100644
index 000000000000..04cec4abf98f
--- /dev/null
+++ b/dev-python/pyscreenshot/pyscreenshot-2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python screenshot library"
+HOMEPAGE="https://github.com/ponty/pyscreenshot"
+SRC_URI="https://github.com/ponty/pyscreenshot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ media-gfx/pqiv
+ kde-apps/gwenview
+ x11-apps/xdpyinfo
+)"
+
+DEPEND="
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/entrypoint2[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+ dev-python/mss[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needs access to dbus
+ sed -i -e 's:test_kwin_dbus:_&:' \
+ tests/test_kwin_dbus.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx pytest -vv
+}